reply 0.1.2-dev

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 1

Utilities for recording and replaying API interactions

Changelog

0.1.2-dev

  • Add support for JSON encoding
  • Enable creating a Recording object from a set of records

0.1.1-dev

  • Add support for a custom Equality object for matching requests

0.1.0-dev

  • Initial commit; supports basic record/reply functionality

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  reply: ^0.1.2-dev

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:reply/reply.dart';
  
Version Uploaded Documentation Archive
0.1.2-dev Nov 14, 2016 Go to the documentation of reply 0.1.2-dev Download reply 0.1.2-dev archive
0.1.0-dev Nov 13, 2016 Go to the documentation of reply 0.1.0-dev Download reply 0.1.0-dev archive
Popularity:
Describes how popular the package is relative to other packages. [more]
3
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
1
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0-dev <2.0.0