resize_sensor_component 0.0.1

  • README.md
  • Installing
  • Versions
  • 0
@Component(
   selector: 'my-component',
   directives: const[ResizeSensor],
   template: r'''
   <div>
     some content
     <resize-sensor (resize)="$event"></resize-sensor>
   </div>
''')
   class MyComponent{
     void resize(ResizeEvent event){
       print("${event.width} ${event.height}");
     }
   }

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  resize_sensor_component: ^0.0.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:resize_sensor_component/resize_sensor_component.dart';
  
Version Uploaded Documentation Archive
0.0.1 Apr 16, 2017 Go to the documentation of resize_sensor_component 0.0.1 Download resize_sensor_component 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0