respect_24_hour 0.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 65

respect_24_hour #

This project makes it possible to check whether the device is using 12 or 24 hour time.

Supported Platforms #

  • Android API 16+ (4.1+, the minimum version supported by Flutter).
  • iOS 8.0+ (the minimum version supported by Flutter).

Getting Started #

There is only one getter which is static and can be called anywhere.

//returns bool indicative of whether the device is using 24-hour time format
await Respect24Hour.get24HourFormat;

0.0.1 #

  • Added support for iOS and Android

example/README.md

respect_24_hour_example #

Demonstrates how to use the respect_24_hour plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  respect_24_hour: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:respect_24_hour/respect_24_hour.dart';
  
Version Uploaded Documentation Archive
0.0.2 Jan 1, 2019 Go to the documentation of respect_24_hour 0.0.2 Download respect_24_hour 0.0.2 archive
0.0.1 Jan 1, 2019 Go to the documentation of respect_24_hour 0.0.1 Download respect_24_hour 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
33
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
90
Overall:
Weighted score of the above. [more]
65
Learn more about scoring.

We analyzed this package on Feb 20, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13+1
  • Flutter: 1.2.1

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Format lib/respect_24_hour.dart.

Run flutter format to format lib/respect_24_hour.dart.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8