to include this driver in your own project add the package to your pubspec.yaml file:
dependencies: rethinkdb_driver: '^2.3.2+2'
or to use bleeding edge:
dependencies: rethinkdb_driver: git: git://github.com/billysometimes/rethinkdb.git
or if you are a developer:
dependencies: rethinkdb_driver: path: /path/to/your/cloned/rethinkdb_driver
then import the package into your project:
to run tests execute the following command from the project root:
warning: tests are run against a live database, but they do attempt to clean up after themselves
pub run test
Add this to your package's pubspec.yaml file:
dependencies: rethinkdb_driver: ^2.3.2+2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|2.3.2+2||Apr 24, 2018|
|2.3.2+1||Oct 15, 2017|
|2.3.2||Oct 14, 2017|
|2.3.1||Sep 11, 2016|
|2.3.0||May 31, 2016|
|2.2.0||May 27, 2016|
|2.0.3+1||Jul 4, 2015|
|2.0.3||Jun 29, 2015|
|2.0.1+1||May 6, 2015|
|2.0.1||Apr 22, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.13.0 <2.0.0|