revolver 1.3.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

Automatically reloads your command line application when changes to files are detected. Monitoring occurs on files within the current path, recursively.

Check the documentation for extra functionality using the API.

Revolver was influenced by Nodemon.

Installation

pub global activate revolver

Usage

revolver [options...] application [application arguments...]
$ revolver --help
-e, --ext                 Watch only the specified extensions.
-w, --working-dir         Overrides the current working directory,.
                          (defaults to "/files/projects/dart/revolver")

-p, --use-polling         Using file polling, rather than file system events, to detect file changes.
-h, --help                Displays this help information.
-g, --[no-]git            Ignores git files and respects the contents of .gitignore.
                          (defaults to on)

-d, --[no-]ignore-dart    Ignore dart project files.
                          (defaults to on)

Examples

$ revolver --ext="dart,yaml,conf" application.dart
Start.     application.dart
Modified.  application.dart
Reload.    application.dart
$ revolver --git bin/server.dart -p 8080
Start.     bin/server.dart
New File.  bin/test1
Reload.    bin/server.dart
Deleted.   bin/test1
Reload.    bin/server.dart
Version 1.0.0
  • Initial release.
Version 1.0.1
  • Fixed issue with displaying usage.

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate revolver

2. Use it

The package has the following executables:


$ revolver

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  revolver: ^1.3.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:revolver/revolver.dart';
  
Version Uploaded Documentation Archive
1.3.0 Nov 22, 2017 Go to the documentation of revolver 1.3.0 Download revolver 1.3.0 archive
1.2.1 Aug 2, 2017 Go to the documentation of revolver 1.2.1 Download revolver 1.2.1 archive
1.2.0 Aug 1, 2017 Go to the documentation of revolver 1.2.0 Download revolver 1.2.0 archive
1.1.0 Jul 30, 2017 Go to the documentation of revolver 1.1.0 Download revolver 1.1.0 archive
1.0.2 Jul 23, 2017 Go to the documentation of revolver 1.0.2 Download revolver 1.0.2 archive
1.0.1+1 Jan 28, 2017 Go to the documentation of revolver 1.0.1+1 Download revolver 1.0.1+1 archive
1.0.1 Feb 23, 2016 Go to the documentation of revolver 1.0.1 Download revolver 1.0.1 archive
1.0.0 Feb 22, 2016 Go to the documentation of revolver 1.0.0 Download revolver 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because revolver depends on ansicolor >=0.0.2 <1.0.1 which requires SDK version <2.0.0, version solving failed.

Health suggestions

Format bin/revolver.dart.

Run dartfmt to format bin/revolver.dart.

Format lib/revolver.dart.

Run dartfmt to format lib/revolver.dart.

Format lib/src/file_filter.dart.

Run dartfmt to format lib/src/file_filter.dart.

Fix additional 4 files with analysis or formatting issues.

Additional issues in the following files:

  • lib/src/file_util.dart (Run dartfmt to format lib/src/file_util.dart.)
  • lib/src/file_watcher.dart (Run dartfmt to format lib/src/file_watcher.dart.)
  • lib/src/messaging.dart (Run dartfmt to format lib/src/messaging.dart.)
  • lib/src/project_template.dart (Run dartfmt to format lib/src/project_template.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use revolver.dart.

Package is getting outdated. (-6.85 points)

The package was released 55 weeks ago.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0