rewrites 0.1.0

  • Installing
  • Versions
  • 0

PubServe Rewrites #

This library is highly experimental and its purpose is to be used during development.

Feedback and PR's are welcome

Why #

To help pub serve to support apps using HTML5 pushState for navigation during development.

Rewrite uses pattern matching to check if a given URL will be ignored or if changed to a new destination URL.

Install #

> pub global activate --source git

How to use #

Create a rewrites.yaml file in the root of your project (same folder as your pubspec.yaml) and setup your rewrite rules.

In the example bellow all json|html|js|dart|css|png will be ignored and the server proxied decide what will be served.

When the browser makes a request to eg: /admin/dashboard it will receive the content of admin.html.

All others requests that are not ignored or that matches with /admin/(.*) will be proxied to index.html.

# rewrites.yaml
- ^(\S+\.(json|html|js|dart|css|png))$
- rewrite: /admin/(.*)
  to: admin.html
- rewrite: (.*)
  to: index.html

Run the following code in your terminal

> rewrites

If you need help run the command bellow

> rewrites --help

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate rewrites

2. Use it

The package has the following executables:

$ rewrites

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  rewrites: ^0.1.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:rewrites/rewrites.dart';
Version Uploaded Documentation Archive
0.1.0 Nov 29, 2016 Go to the documentation of rewrites 0.1.0 Download rewrites 0.1.0 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0