This library is highly experimental and its purpose is to be used during development.
Feedback and PR's are welcome
pub serve to support apps using HTML5 pushState for navigation during development.
Rewrite uses pattern matching to check if a given URL will be ignored or if changed to a new destination URL.
> pub global activate --source git https://github.com/adaojunior/pub_serve_rewrites.git
rewrites.yaml file in the root of your project (same folder as your
pubspec.yaml) and setup your rewrite rules.
In the example bellow all
json|html|js|dart|css|png will be ignored and the server proxied decide what will be served.
When the browser makes a request to eg:
/admin/dashboard it will receive the content of
All others requests that are not ignored or that matches with
/admin/(.*) will be proxied to
# rewrites.yaml ignore: - ^(\S+\.(json|html|js|dart|css|png))$ rewrites: - rewrite: /admin/(.*) to: admin.html - rewrite: (.*) to: index.html
Run the following code in your terminal
If you need help run the command bellow
> rewrites --help
You can install the package from the command line:
$ pub global activate rewrites
The package has the following executables:
Add this to your package's pubspec.yaml file:
dependencies: rewrites: ^0.1.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.1.0||Nov 29, 2016|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
dartdoc successfully runs on your package's source files. (-10 points)
Dependencies were not resolved.
|Dart SDK||>=1.8.0 <2.0.0|