rikulo 0.6.3

  • README.md
  • Installing
  • Versions
  • 0

#Rikulo is now Rikulo UI

This package has moved to rikulo_ui.

To upgrade, please follow the instructions here.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rikulo: ^0.6.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rikulo/effect.dart';
import 'package:rikulo/event.dart';
import 'package:rikulo/gesture.dart';
import 'package:rikulo/html.dart';
import 'package:rikulo/layout.dart';
import 'package:rikulo/message.dart';
import 'package:rikulo/model.dart';
import 'package:rikulo/view.dart';
import 'package:rikulo/view/impl.dart';
import 'package:rikulo/view/select.dart';
  
Version Uploaded Documentation Archive
0.6.3 Feb 7, 2013 Go to the documentation of rikulo 0.6.3 Download rikulo 0.6.3 archive
0.6.2+2 Jan 28, 2013 Go to the documentation of rikulo 0.6.2+2 Download rikulo 0.6.2+2 archive
0.6.2+1 Jan 14, 2013 Go to the documentation of rikulo 0.6.2+1 Download rikulo 0.6.2+1 archive
0.6.2 Jan 9, 2013 Go to the documentation of rikulo 0.6.2 Download rikulo 0.6.2 archive
0.6.1 Dec 14, 2012 Go to the documentation of rikulo 0.6.1 Download rikulo 0.6.1 archive
0.6.0 Nov 6, 2012 Go to the documentation of rikulo 0.6.0 Download rikulo 0.6.0 archive
0.5.0 Oct 12, 2012 Go to the documentation of rikulo 0.5.0 Download rikulo 0.5.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Make sure dartfmt runs.

Running dartfmt -n . failed with the following output:

Exception: dartfmt on lib/ failed with exit code 65
Could not format because the source could not be parsed:

line 33, column 9 of lib/src/view/_StyleImpl.dart: Expected an identifier.
    if (?priority)
        ^
line 33, column 18 of lib/src/view/_StyleImpl.dart: Expected to find ':'.
    if (?priority)
                 ^
line 33, column 18 of lib/src/view/_StyleImpl.dart: Expected an identifier.

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 
 Because rikulo depends on browser any which requires SDK version <2.0.0, version solving failed.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Make sure dartfmt runs.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use rikulo.dart. Packages with multiple examples should use example/readme.md.