rikulo_highcharts 1.0.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 71

highcharts

highcharts is a wrapper of Highcharts in Dart.

Install from Dart Pub Repository

Include the following in your pubspec.yaml:

dependencies:
  rikulo_highcharts: any

Then run the Pub Package Manager in Dart Editor (Tool > Pub Install). If you are using a different editor, run the command (comes with the Dart SDK):

pub install

Usage

Add this lines to the main html of your application (index.html) in the head section.

<script src="your-js-lib/highcharts.js"></script>

You can create a chart object and chart model.

  import 'dart:html';
import 'package:rikulo_highcharts/highcharts.dart';

main() {
  ColumnChart chart = new ColumnChart();
  querySelector('#cnt').append(chart.element);

  CategoryModel<String, String> model = new DefaultCategoryModel<String, String>();
  model.setValue('Tokyo', 'Jan', 16);
  model.setValue('Tokyo', 'Feb', 6);
  model.setValue('Tokyo', 'Mar', 6);
  model.setValue('Tokyo', 'Apr', 3);

  model.setValue('New York', 'Jan', 18);
  model.setValue('New York', 'Feb', 12);
  model.setValue('New York', 'Mar', 9);
  model.setValue('New York', 'Apr', 14);

  chart.model = model;
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Who Uses

  • Quire - a simple, collaborative, multi-level task management tool.

CHANGES

1.0.0

  • Dart 2 required

0.1.1

  • Add implementation of DonutChart, AreaChart, PieChart
  • Add DefaultSingleValueCategoryModel, DonutModel
  • Fixed dart2js error when using formatter
  • Added setSize reflow APIs

0.1.0

  • Add ColumnChart, DonutChart, AreaChart
  • Add DefaultCategoryModel

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rikulo_highcharts: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rikulo_highcharts/highcharts.dart';
  
Version Uploaded Documentation Archive
1.0.0 Aug 9, 2018 Go to the documentation of rikulo_highcharts 1.0.0 Download rikulo_highcharts 1.0.0 archive
0.1.1 May 17, 2018 Go to the documentation of rikulo_highcharts 0.1.1 Download rikulo_highcharts 0.1.1 archive
0.1.0+5 Apr 17, 2017 Go to the documentation of rikulo_highcharts 0.1.0+5 Download rikulo_highcharts 0.1.0+5 archive
0.1.0+4 Apr 7, 2017 Go to the documentation of rikulo_highcharts 0.1.0+4 Download rikulo_highcharts 0.1.0+4 archive
0.1.0+3 Mar 30, 2017 Go to the documentation of rikulo_highcharts 0.1.0+3 Download rikulo_highcharts 0.1.0+3 archive
0.1.0+2 Mar 23, 2017 Go to the documentation of rikulo_highcharts 0.1.0+2 Download rikulo_highcharts 0.1.0+2 archive
0.1.0+1 Mar 23, 2017 Go to the documentation of rikulo_highcharts 0.1.0+1 Download rikulo_highcharts 0.1.0+1 archive
0.1.0 Mar 23, 2017 Go to the documentation of rikulo_highcharts 0.1.0 Download rikulo_highcharts 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
62
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: web

Platform components identified in package: html, js.

Health suggestions

Format lib/highcharts.dart.

Run dartfmt to format lib/highcharts.dart.

Format lib/src/chart.dart.

Run dartfmt to format lib/src/chart.dart.

Format lib/src/chart_model.dart.

Run dartfmt to format lib/src/chart_model.dart.

Format lib/src/highcharts_js.dart.

Run dartfmt to format lib/src/highcharts_js.dart.

Maintenance issues and suggestions

Use constrained dependencies. (-20 points)

The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: js.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use rikulo_highcharts.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
js any 0.6.1+1