ripple 0.5.3

  • Installing
  • Versions
  • 29


Lightweight Dart messaging server; supporting STOMP messaging protocol.

See also Stomp Dart Client.

Build Status


Add this to your pubspec.yaml (or create it):


Then run the Pub Package Manager (comes with the Dart SDK):

pub install


First, you have to import:

import "package:ripple/ripple.dart";

Then, you can start Ripple server by binding it to any number of Internet addresses and ports.

new RippleServer()
  ..start() //bind to port 61626
  ..startSecure(); //bind to port 61627 and using SSL

For how to use a STOMP client to access Ripple server, please refer to STOMP Dart Client.


You can have Ripple server to serve a WebSocket connection. For example,

HttpServer httpServer;
RippleServer rippleServer;
httpServer.listen((request) {
  if (...) { //usually test request.uri to see if it is mapped to WebSocket
    WebSocketTransformer.upgrade(request).then((WebSocket webSocket) {
    }).catchError((ex) {
      // Handle error
  } else {
    // Do normal HTTP request processing.


  • Support STOMP 1.2 or above
  • Support UTF-8 encoding


  • Transaction not supported.
  • Heart beat not supported.
  • ACK and NACK not supported.

##Potential Enhancement

  • Support subscribeBlob() better. Currently, messages will be held in the memory before sending to subscribers. It could be an issue if the message is huge.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  ripple: "^0.5.3"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:ripple/ripple.dart';
Version Uploaded Documentation Archive
0.5.3 Nov 5, 2013 Go to the documentation of ripple 0.5.3 Download ripple 0.5.3 archive
0.5.2 Oct 29, 2013 Go to the documentation of ripple 0.5.2 Download ripple 0.5.2 archive
0.5.1 Aug 15, 2013 Go to the documentation of ripple 0.5.1 Download ripple 0.5.1 archive
0.5.0 Aug 14, 2013 Go to the documentation of ripple 0.5.0 Download ripple 0.5.0 archive


We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
95 / 100
Reflects how tidy and up-to-date the package is. [more]
0 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:ripple/ripple.dart with components: io.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • Use constrained dependencies.

    The pubspec.yaml contains 3 dependencies without version constraints. Specify version ranges for the following dependencies: logging, rikulo_commons, stomp.

  • Package is too old.

    The package was released more than two years ago.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 10 hints.

    Strong-mode analysis of lib/src/server_impl.dart failed with the following error:

    line: 69 col: 51
    The argument type 'String' can't be assigned to the parameter type 'SecurityContext'.

    Run dartfmt to format lib/plugin.dart.

    Similar analysis of the following files failed:

    • lib/ripple.dart (hint)
    • lib/src/connect.dart (hint)
    • lib/src/connect_impl.dart (hint)
    • lib/src/connect_util.dart (hint)
  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use ripple.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=0.8.7
logging any 0.11.3+1
rikulo_commons any 2.3.9
stomp any 0.7.3
Transitive dependencies
matcher 0.12.3
meta 1.1.5
mime 0.9.6+1
path 1.6.1
quiver 0.29.0+1
stack_trace 1.9.2