ris_parser 1.0.0

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 46

Dart parser for RIS text format.

Usage

A simple usage example:

import 'package:ris_parser/ris_parser.dart';

main() {
  var risText = '''
TY  - JOUR
AU  - Shannon, Claude E.
PY  - 1948/07//
TI  - A Mathematical Theory of Communication
T2  - Bell System Technical Journal
SP  - 379
EP  - 423
VL  - 27
ER  - 
''';

  Iterable<RisRecord> records = parseRis(risText);
  print(records);
}

Features and bugs

Please file feature requests and bugs at the issue tracker.

Credentials

Inspired by A very simple RIS file parser

1.0.0

  • Initial version, created by Stagehand

example/ris_parser_example.dart

import 'package:ris_parser/ris_parser.dart';

main() {
  var risText = '''
TY  - JOUR
AU  - Shannon, Claude E.
PY  - 1948/07//
TI  - A Mathematical Theory of Communication
T2  - Bell System Technical Journal
SP  - 379
EP  - 423
VL  - 27
ER  - 
''';

  Iterable<RisRecord> records = parseRis(risText);
  print(records);
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  ris_parser: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:ris_parser/ris_parser.dart';
  
Version Uploaded Documentation Archive
1.0.0 Sep 12, 2018 Go to the documentation of ris_parser 1.0.0 Download ris_parser 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
46
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:ris_parser/ris_parser.dart.

Health suggestions

Format lib/src/ris_parser_base.dart.

Run dartfmt to format lib/src/ris_parser_base.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.23.0 <3.0.0
Dev dependencies
test any