root_access 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 71

pub package

Root access Plugin

A Flutter plugin for getting root access in Android apps.

This plugin is based on RootTools by Stericson.

This plugin is only for Android platform.

Usage

Import the root_access plugin

Follow the plugin installation instructions.

Use the plugin

import 'package:root_access/root_access.dart';

Define a bool variable and assign a value

bool _rootStatus = false;

The RootAccess class provides a getter to get root access and status

bool rootStatus = await RootAccess.rootAccess;

Declare an async method to retrieve root access

Future<void> initRootRequest() async {
    bool rootStatus = await RootAccess.rootAccess;
    setState(() {
      _rootStatus = rootStatus;
    });
  }

Later you can use _rootStatus in your code to let app know the status of root access. If it's false then root access is not granted in access prompt dialog and if it's true then root access has been granted to the app.

Example

See the example application source for a complete sample app using the Root Access plugin.

Issues and feedback

Please file issues to send feedback or report a bug. Thank you!

1.0.1

  • Fix documentation
  • Apply Flutter suggestions

example/lib/main.dart

import 'package:flutter/material.dart';
import 'dart:async';

import 'package:root_access/root_access.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  _MyAppState createState() => new _MyAppState();
}

class _MyAppState extends State<MyApp> {
  bool _rootAccess = false;

  @override
  void initState() {
    super.initState();
    initRootRequest();
  }

  Future<void> initRootRequest() async {
    bool rootAccess = await RootAccess.rootAccess;

    // If the widget was removed from the tree while the asynchronous platform
    // message was in flight, we want to discard the reply rather than calling
    // setState to update our non-existent appearance.
    if (!mounted) return;

    setState(() {
      _rootAccess = rootAccess;
    });
  }

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      home: new Scaffold(
        appBar: new AppBar(
          title: const Text('Plugin example app'),
        ),
        body: new Center(
          child: new Text('Root access granted: $_rootAccess\n'),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  root_access: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:root_access/root_access.dart';
  
Version Uploaded Documentation Archive
1.0.1 Jul 26, 2018 Go to the documentation of root_access 1.0.1 Download root_access 1.0.1 archive
1.0.0 Jul 26, 2018 Go to the documentation of root_access 1.0.0 Download root_access 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Oct 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.4
  • Flutter: 0.9.5

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.58.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8