routes 0.1.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 2

##ROUTES 0.1.3

Is a simple server routing via a single routes.dart file

routes builds on route and params package route and params

  1. add dependencies to pubspec

    route: "^0.4.6"
    
    routes: "^0.1.4"
    
  2. create a routes file ###ROUTES

inside projectRootFolder/routes.dart

   part of sampleServerGui;
  
   final Map serverRoutes={
     'byeJs':{'url':new UrlPattern(r'/byeJs'),'action': byeJs,'async':true },
     'helloDart':{'url':new UrlPattern(r'/helloDart'),'method':'GET','action': helloDart }
   };

here we see 2 routes 'byeJs' and 'helloDart'

routes always have a

url -> url pattern and an

action -> called method and an optional

method -> that currently handels 'PUT' and 'GET'

  1. create the simple server with functions for each specified action (helloDart,byeJs) ###SERVER

projectRootFolder/bin/simpleServer.dart

   library sampleServerGui;
   
   import "dart:io";
   import 'dart:convert';
   import 'package:route/url_pattern.dart';
   import 'package:routes/server.dart';
  
   part '../routes.dart';
   
   final String HOST = "127.0.0.1"; // eg: localhost
   
   final num PORT = 8079;
   
   main() async {
       var server = await HttpServer.bind(HOST, PORT);
       var router = initRouter(server, serverRoutes);
       print("Listening for GET and POST on http://$HOST:$PORT");
   }
  
   void printError(error) => print(error);
  
   helloDart(Map params, HttpResponse res){
     Map newMap = {"language":params["language"]};
     if(params["language"] == "Dart"){
       newMap["text"]="Hello";
     }else{
       newMap["text"]="GOODBYE";
     }
     res.write(JSON.encode(newMap));
     res.close();
   }

   byeJs(Map params, HttpResponse res){
     //do stuff
   }

now you can talk to the server eg with http://127.0.0.1:8079/helloDart?language=Dart


###WHATS HAPPENING

the Magic happens here

  var router = initRouter(server, serverRoutes);
  

it automatically generates a router that will use the specified routes in routes.dart

the action specified inside the routes will recieve 2 parameters

**a Map params **-> including the parameters send in the request **a HTTPResponse res **


Download a working example here

VERSION

0.1.3 -added changelog.md
0.1.2 -remove filter again for now
0.1.1 -fix readme
      -added filter for router
0.1.0 -removed rootPath parameter from InitRouter() function
      -added readme.md and license.md
0.0.1 -initial commit supports server routing

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  routes: ^0.1.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:routes/client.dart';
import 'package:routes/server.dart';
  
Version Uploaded Documentation Archive
0.1.4 May 11, 2016 Go to the documentation of routes 0.1.4 Download routes 0.1.4 archive
0.1.3 Aug 13, 2014 Go to the documentation of routes 0.1.3 Download routes 0.1.3 archive
0.1.2 Aug 13, 2014 Go to the documentation of routes 0.1.2 Download routes 0.1.2 archive
0.1.1 Aug 13, 2014 Go to the documentation of routes 0.1.1 Download routes 0.1.1 archive
0.1.0 Aug 13, 2014 Go to the documentation of routes 0.1.0 Download routes 0.1.0 archive
0.0.1 Aug 12, 2014 Go to the documentation of routes 0.0.1 Download routes 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.4.0 <2.0.0