rp_web_ui 0.0.11

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 24

An absolute bare-bones web app.

Created from templates made available by Stagehand under a BSD-style license.

1.0.0 #

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  rp_web_ui: ^0.0.11

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:rp_web_ui/rp_web_ui.dart';
  
Version Uploaded Documentation Archive
0.0.11 Mar 20, 2019 Go to the documentation of rp_web_ui 0.0.11 Download rp_web_ui 0.0.11 archive
0.0.1 Mar 20, 2019 Go to the documentation of rp_web_ui 0.0.1 Download rp_web_ui 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
19
Health:
Code health derived from static analysis. [more]
27
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
30
Overall:
Weighted score of the above. [more]
24
Learn more about scoring.

We analyzed this package on Apr 19, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14

Platforms

Detected platforms:

Error(s) prevent platform classification:

Error(s) in lib/routes.dart: Target of URI hasn't been generated: 'storybook/rp_range_book/rp_range_book.template.dart'.

Health issues and suggestions

Fix lib/routes.dart. (-43.75 points)

Analysis of lib/routes.dart failed with 2 errors:

line 6 col 8: Target of URI hasn't been generated: 'storybook/rp_range_book/rp_range_book.template.dart'.

line 7 col 8: Target of URI hasn't been generated: 'storybook/rp_modal_book/rp_modal_book.template.dart'.

Fix lib/components/rp_range/rp_range.dart. (-4.89 points)

Analysis of lib/components/rp_range/rp_range.dart reported 10 hints, including:

line 4 col 8: Unused import: 'package:stream_transform/stream_transform.dart'.

line 78 col 10: The value of the field '_moveFromPosition' isn't used.

line 79 col 10: The value of the field '_moveToPosition' isn't used.

line 80 col 10: The value of the field '_zoomPosition' isn't used.

line 91 col 7: The value of the field '_centerBtnPossitionEnd' isn't used.

Fix lib/rp_web_ui.dart. (-1 points)

Analysis of lib/rp_web_ui.dart reported 2 hints:

line 1 col 8: Unused import: 'components/rp_modal/rp_modal.dart'.

line 2 col 8: Unused import: 'components/rp_range/rp_range.dart'.

Fix additional 4 files with analysis or formatting issues. (-2.50 points)

Additional issues in the following files:

  • lib/storybook/rp_modal_book/rp_modal_book.dart (2 hints)
  • lib/storybook/rp_range_book/rp_range_book.dart (2 hints)
  • lib/components/rp_modal/rp_modal.dart (1 hint)
  • lib/index.dart (Run dartfmt to format lib/index.dart.)

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Error(s) in lib/routes.dart: Target of URI hasn't been generated: 'storybook/rp_range_book/rp_range_book.template.dart'.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

exitCode: 255 stdout: parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/routes.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/rp_web_ui.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/storybook/rp_range_book/rp_range_book.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/storybook/rp_modal_book/rp_modal_book.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/index.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/route_paths.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/components/rp_modal/rp_modal.dart... parsing /tmp/pub-dartlang-dartdocJLLBES/pkg/lib/components/rp_range/rp_range.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/angular_router-2.0.0-alpha+21/lib/angular_router.dart... parsing /dart-sdk/lib/core/core.dart... parsing /dart-sdk/lib/collection/collection.dart... parsing /dart-sdk/lib/internal/internal.dart... parsing /dart-sdk/lib/async/async.dart... parsing /dart-sdk/lib/convert/convert.dart... parsing /dart-sdk/lib/typed_data/typed_data.dart... parsing /dart-sdk/lib/math/math.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/angular_router-2.0.0-alpha+21/lib/src/constants.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/angular-5.2.0/lib/angular.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/angular-5.2.0/lib/core.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/angular-5.2.0/lib/src/core/application_tokens.dart... [...] parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/double_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/uri_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/bool_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_json_serializers.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_list_multimap_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_list_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_map_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_set_multimap_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/built_set_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/int_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/regexp_serializer.dart... parsing /tmp/pub-cache-dirDAHAUL/hosted/pub.dartlang.org/built_value-6.4.0/lib/src/string_serializer.dart... Initialized dartdoc with 1065 libraries in 129.5 seconds documenting rp_web_ui Generating docs for library index from package:rp_web_ui/index.dart... Generating docs for library route_paths from package:rp_web_ui/route_paths.dart... Generating docs for library routes from package:rp_web_ui/routes.dart... Generating docs for library rp_modal from package:rp_web_ui/components/rp_modal/rp_modal.dart... Generating docs for library rp_modal_book from package:rp_web_ui/storybook/rp_modal_book/rp_modal_book.dart... Generating docs for library rp_modal_book.template from package:rp_web_ui/storybook/rp_modal_book/rp_modal_book.template.dart... stderr: Documenting rp_web_ui... warning: no canonical library found for index.AppComponent.hashCode, not linking, from index.AppComponent.hashCode: (file:///dart-sdk/lib/core/object.dart) warning: no canonical library found for index.AppComponent.runtimeType, not linking, from index.AppComponent.runtimeType: (file:///dart-sdk/lib/core/object.dart) warning: no canonical library found for index.AppComponent.noSuchMethod, not linking, from index.AppComponent.noSuchMethod: (file:///dart-sdk/lib/core/object.dart:109:20) warning: no canonical library found for index.AppComponent.toString, not linking, from index.AppComponent.toString: (file:///dart-sdk/lib/core/object.dart:97:19) warning: no canonical library found for index.AppComponent.==, not linking, from index.AppComponent.==: (file:///dart-sdk/lib/core/object.dart:60:26) Unhandled exception: FileSystemException: Cannot open file, path = '/tmp/pub-dartlang-dartdocJLLBES/pkg/lib/storybook/rp_modal_book/rp_modal_book.template.dart' (OS Error: No such file or directory, errno = 2) #0 _File.throwIfError (dart:io/file_impl.dart:643:7) #1 _File.openSync (dart:io/file_impl.dart:487:5) #2 _File.readAsBytesSync (dart:io/file_impl.dart:547:18) #3 _File.readAsStringSync (dart:io/file_impl.dart:592:18) #4 LineNumberCache._fileContents.<anonymous closure> (package:dartdoc/src/line_number_cache.dart:56:61) #5 __InternalLinkedHashMap&_HashVMBase&MapMixin&_LinkedHashMapMixin.putIfAbsent (dart:collection/runtime/libcompact_hash.dart:281:23) #6 LineNumberCache._fileContents (package:dartdoc/src/line_number_cache.dart:56:22) #7 LineNumberCache.lineAndColumn.<anonymous closure> (package:dartdoc/src/line_number_cache.dart:47:43) #8 __InternalLinkedHashMap&_HashVMBase&MapMixin&_LinkedHashMapMixin.putIfAbsent (dart:collection/runtime/libcompact_hash.dart:281:23) #9 LineNumberCache.lineAndColumn (package:dartdoc/src/line_number_cache.dart:46:32) #10 ModelElement.lineAndColumn (package:dartdoc/src/model.dart:3499:40) #11 new SourceLinker.fromElement (package:dartdoc/src/source_linker.dart:88:27) #12 ModelElement.sourceHref (package:dartdoc/src/model.dart:3222:25) #13 ModelElement.hasSourceHref (package:dartdoc/src/model.dart:3219:29) #14 _LocalInstanceMirror._invokeGetter (dart:mirrors/runtime/libmirrors_impl.dart:329:76) #15 _LocalInstanceMirror.getField (dart:mirrors/runtime/libmirrors_impl.dart:296:20) #16 Renderer._getNamedProperty (package:mustache/src/renderer.dart:245:29) #17 Renderer.resolveValue (package:mustache/src/renderer.dart:212:16) #18 Renderer._renderSection (package:mustache/src/renderer.dart:120:17) #19 Renderer.visitSection (package:mustache/src/renderer.dart:115:7) #20 SectionNode.accept (package:mustache/src/node.dart:63:43) #21 Renderer.render.<anonymous closure> (package:mustache/src/renderer.dart:58:30) #22 List.forEach (dart:core/runtime/libgrowable_array.dart:278:8) #23 Renderer.render (package:mustache/src/renderer.dart:58:13) #24 Renderer.visitPartial (package:mustache/src/renderer.dart:195:16) #25 PartialNode.accept (package:mustache/src/node.dart:81:43) #26 SectionNode.visitChildren.<anonymous closure> (package:mustache/src/node.dart:66:37) #27 List.forEach (dart:core/runtime/libgrowable_array.dart:278:8) #28 SectionNode.visitChildren (package:mustache/src/node.dart:66:14) #29 Renderer._renderWithValue (package:mustache/src/renderer.dart:184:10) #30 Renderer._renderSection (package:mustache/src/renderer.dart:144:7) #31 Renderer.visitSection (package:mustache/src/renderer.dart:115:7) #32 SectionNode.accept (package:mustache/src/node.dart:63:43) #33 Renderer.render.<anonymous closure> (package:mustache/src/renderer.dart:58:30) #34 List.forEach (dart:core/runtime/libgrowable_array.dart:278:8) #35 Renderer.render (package:mustache/src/renderer.dart:58:13) #36 Template.render (package:mustache/src/template.dart:40:14) #37 Template.renderString (package:mustache/src/template.dart:33:5) #38 HtmlGeneratorInstance._build (package:dartdoc/src/html/html_generator_instance.dart:381:31) #39 HtmlGeneratorInstance.generateLibrary (package:dartdoc/src/html/html_generator_instance.dart:269:5) #40 HtmlGeneratorInstance._generateDocs (package:dartdoc/src/html/html_generator_instance.dart:131:9) #41 HtmlGeneratorInstance.generate (package:dartdoc/src/html/html_generator_instance.dart:36:7) <asynchronous suspension> #42 HtmlGenerator.generate (package:dartdoc/src/html/html_generator.dart:108:23) <asynchronous suspension> #43 Dartdoc.generateDocsBase (package:dartdoc/dartdoc.dart:107:25) <asynchronous suspension> #44 Dartdoc.generateDocs (package:dartdoc/dartdoc.dart:134:43) <asynchronous suspension> #45 main (file:///project/pkg/pub_dartdoc/bin/pub_dartdoc.dart:27:17) <asynchronous suspension> #46 _startIsolate.<anonymous closure> (dart:isolate/runtime/libisolate_patch.dart:298:32) #47 _RawReceivePortImpl._handleMessage (dart:isolate/runtime/libisolate_patch.dart:171:12)

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package.

Common filename patterns include main.dart, example.dart, and rp_web_ui.dart. Packages with multiple examples should provide example/README.md.

For more information see the pub package layout conventions.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
angular ^5.2.0 5.2.0 5.3.0
angular_router ^2.0.0-alpha+21 2.0.0-alpha+21 2.0.0-alpha+22
stream_transform ^0.0.16 0.0.17
Transitive dependencies
analyzer 0.34.3 0.36.0
angular_ast 0.5.8 0.5.9
angular_compiler 0.4.2 0.4.3
args 1.5.1
async 2.2.0
build 1.1.0 1.1.3
build_config 0.3.2
built_collection 4.2.0
built_value 6.4.0
charcode 1.1.2
code_builder 3.2.0
collection 1.14.11
convert 2.1.1
crypto 2.0.6
csslib 0.14.6 0.15.0
fixnum 0.10.9
front_end 0.1.9+1 0.1.15
glob 1.1.7
html 0.14.0+1
intl 0.15.8
json_annotation 2.2.0
kernel 0.3.9+1 0.3.15
logging 0.11.3+2
matcher 0.12.5
meta 1.1.7
package_config 1.0.5
path 1.6.2
plugin 0.2.0+3
pub_semver 1.4.2
pubspec_parse 0.1.4
quiver 2.0.3
source_gen 0.9.4+1 0.9.4+2
source_span 1.5.5
stack_trace 1.9.3
string_scanner 1.0.4
term_glyph 1.1.0
typed_data 1.1.6
watcher 0.9.7+10
yaml 2.1.15
Dev dependencies
angular_test ^2.2.0
build_runner ^1.1.2
build_test ^0.10.3
build_web_compilers ^1.0.0
built_value_generator ^6.3.1
coverage ^0.12.4
dart_dev ^2.0.3
dart_style ^1.2.3 1.2.3 1.2.7
dartdoc ^0.28.0
js ^0.6.0 0.6.1+1
pedantic ^1.0.0
sass_builder ^2.0.0
test ^1.5.1