rpi_gpio is a Dart library for accessing the Raspberry Pi GPIO pins.
Gpio provides a high level API for accessing the various General Purpose I/O pins on the Raspberry Pi.
RpiHardware provides a low level API for accessing the GPIO pins.
The rpi_gpio library accesses the GPIO pins using a native library written in C and built on top of the wiringPi library. For security reasons, authors cannot publish binary content to pub.dartlang.org, so there are some extra steps necessary to compile the native library on the RPi before this package can be used. These two steps must be performed when you install and each time you upgrade the rpi_gpio package.
pub global activate rpi_gpio
pub global run rpi_gpio:build_lib
pub global activate makes the Dart scripts in the rpi_gpio/bin directory runnable from the command line. pub global run rpi_gpio:build_lib runs the rpi_gpio/bin/build_lib.dart program which in turn calls the build_lib script to compile the native librpi_gpio_ext.so library for the rpi_gpio package.
A read pins example demonstrates reading the current value for multiple pins.
A second read pins example demonstrates mocking the hardware so that the logic can be run and tested on platforms other than the Raspberry Pi.
Add this to your package's pubspec.yaml file:
dependencies: rpi_gpio: ^0.2.2
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.2.2||Dec 25, 2015|
|0.2.1+1||Aug 23, 2015|
|0.2.1||Jul 18, 2015|
|0.2.0||Jul 15, 2015|
|0.1.0||Apr 28, 2015|
|0.4.0-dev.1||Aug 24, 2018|
|0.3.0-dev.1||Jan 2, 2016|
|0.2.0-alpha.2||Jul 5, 2015|
|0.2.0-alpha.1||Jun 23, 2015|
|0.2.0-alpha.0||Jun 14, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.0.0 <2.0.0|