safety_stream_builder 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 74

Safety StreamBuilder for Flutter

For lazy, SafetyStreamBuilder can use with just a little confidence.

Usage

In StreamBuilder, it is necessary to finely implement whether AsyncSnapshot contains data or an error has occurred. SafetyStreamBuilder provides default blank widget and error display widget and direct data. (hiding AsyncSnapshot)

Before: Using Dart standard StreamBuilder

StreamBuilder<String>(
  stream: stream,
  builder: (BuildContext context, AsyncSnapshot<String> snapshot) {
    if (!snapshot.hasData) {
      return Container();
    }
    if (snapshot.hasError) {
      return Icon(Icons.error_outline);
    }
    return Text(snapshot.data);
  },
)

After: Using SafetyStreamBuilder

SafetyStreamBuilder<String>(
  stream: stream,
  builder: (BuildContext context, String message) => Text(message),
);

v0.0.1

  • Initial Release
  • No API Document

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  safety_stream_builder: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:safety_stream_builder/safety_stream_builder.dart';
  
Version Uploaded Documentation Archive
0.0.1 Oct 8, 2018 Go to the documentation of safety_stream_builder 0.0.1 Download safety_stream_builder 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
63
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
74
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use safety_stream_builder.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test