sass 0.4.2+7

  • Installing
  • Versions
  • 85

The name of the package previously published as sass was changed to dart_sass_transformer

to make place for the new Dart-SASS package now published under this name.

To use new dart-sass package see the instructions at dart-sass

Hint: pre-release versions (with a - after the patch version) are listed after other versions. This is the reason the information about the package that was previously published here is still shown instead of the information about the new package. You have to click All x versions... in the Versions tab to get the new version (1.0.0-alpha.x) shown.

v0.4.2 (2014-11-03)

  • Fixed files over 1024 bytes getting truncated on Windows. (#19) (Thanks to Alexander Sergeev.)
  • Normalize the load paths to platform's native format. (Thanks to llamadonica.)

v0.4.1 (2014-10-09)

  • Filter out external packages when resolving imports. (#12) (Thanks to Konstantin Borisov.)

v0.4.0 (2014-09-22)

  • Support for new inlined_sass_transformer. (#4) (Thanks to Dan Schultz.)
  • Require Barback 0.15.x.

v0.3.2 (2014-09-17)

  • Support Barback 0.15.x.

v0.3.1 (2014-06-24)

  • Use sass.bat as default executable on Windows. (#10) (Thanks to Nicholas Tuck.)

v0.3.0 (2014-05-25)

  • Breaking change: don't copy source .scss/.sass files to build directory by default. Use copy-sources: true to keep the old behavior. (#7)
  • Support imports with directory names. (#8)

v0.2.2 (2014-05-23)

  • Require Barback 0.13.x.
  • Fixed DeclaringTransformer on Barback 0.13.x.

v0.2.1 (2014-05-15)

  • Implemented DeclaringTransformer interface so Barback can optimize the asset graph.
  • Compatibility with Barback 0.13.x.

v0.2.0 (2014-05-15)

  • Exclude URL-imports when parsing imports. (Thanks to Vikraman Choudhury.)

v0.1.1 (2014-04-24)

  • Ignore Compass imports when reading the dependencies of a module. (Thanks to Dan Schultz.)

v0.1.0 (2014-04-19)

  • Support using SassC instead of vanilla Sass.

1. Depend on it

Add this to your package's pubspec.yaml file:

  sass: "^0.4.2+7"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:sass/sass.dart';
Version Uploaded Documentation Archive
0.4.2+7 Nov 5, 2016 Go to the documentation of sass 0.4.2+7 Download sass 0.4.2+7 archive
0.4.2+5 Nov 5, 2016 Go to the documentation of sass 0.4.2+5 Download sass 0.4.2+5 archive
0.4.2+4 Oct 20, 2016 Go to the documentation of sass 0.4.2+4 Download sass 0.4.2+4 archive
0.4.2+3 Oct 20, 2016 Go to the documentation of sass 0.4.2+3 Download sass 0.4.2+3 archive
0.4.2+2 Oct 19, 2016 Go to the documentation of sass 0.4.2+2 Download sass 0.4.2+2 archive
0.4.2+1 Oct 19, 2016 Go to the documentation of sass 0.4.2+1 Download sass 0.4.2+1 archive
0.4.2 Nov 3, 2014 Go to the documentation of sass 0.4.2 Download sass 0.4.2 archive
0.4.1 Oct 9, 2014 Go to the documentation of sass 0.4.1 Download sass 0.4.1 archive
0.4.0 Sep 22, 2014 Go to the documentation of sass 0.4.0 Download sass 0.4.0 archive
0.3.2 Sep 17, 2014 Go to the documentation of sass 0.3.2 Download sass 0.3.2 archive

All 43 versions...


We analyzed this package on Mar 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.31.0
  • pana: 0.10.3


Describes how popular the package is relative to other packages. [more]
85 / 100
Code health derived from static analysis. [more]
96 / 100
Reflects how tidy and up-to-date the package is. [more]
67 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:sass/sass.dart with components: io.


  • Fix issues reported by dartanalyzer or dartfmt.

    dartanalyzer or dartfmt reported 1 warning 7 hints.

    Strong-mode analysis of lib/src/inlined_sass_file.dart gave the following warning:

    line: 35 col: 37
    A function of type '(_SassImport, _SassImport) → int' can't be assigned to a location of type '(dynamic, dynamic) → int'.

    Run dartfmt to format lib/inlined_sass_transformer.dart.

    Similar analysis of the following files failed:

    • lib/sass.dart (hint)
    • lib/src/base_sass_transformer.dart (hint)
    • lib/src/sass_file.dart (hint)
    • lib/src/transformer_options.dart (hint)
    • lib/transformer.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use sass.dart.


Package Constraint Resolved Available
Direct dependencies
barback >=0.15.0 <0.16.0 0.15.2+14
utf >=0.9.0 <0.9.1 0.9.0+4
Transitive dependencies
async 2.0.6
charcode 1.1.1
collection 1.14.5
path 1.5.1
pool 1.3.4
source_span 1.4.0
stack_trace 1.9.2
Dev dependencies
mock >=0.11.0 <0.13.0
test >=0.12.0 <0.13.0