sass_generator 0.1.0-dev

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 24

A build system for sass-dart

This package is under development. Source code available soon.

Note: This is not an official Google product.

Changelog

0.0.1

  • Initial version, only builds for package-internal tests/examples.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sass_generator: "^0.1.0-dev"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.1.0-dev Nov 13, 2016 Go to the documentation of sass_generator 0.1.0-dev Download sass_generator 0.1.0-dev archive

Analysis

We analyzed this package on Jun 12, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.60.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
52 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
39 / 100
Overall score:
Weighted score of the above. [more]
24
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No libraries.

Suggestions

  • Use constrained dependencies.

    The pubspec.yaml contains 1 dependency without version constraints. Specify version ranges for the following dependencies: sass.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error.

    Strong-mode analysis of lib/src/sass_builder.dart failed with the following error:

    line: 15 col: 12
    The expression in an assert must be of type 'bool'.

  • Package is getting outdated.

    The package was released 82 weeks ago.

  • Package is pre-release.

    Pre-release versions should be used with caution, their API may change in breaking ways.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use sass_generator.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.0 <2.0.0
build >=0.5.0 <0.6.0 0.5.0 0.12.6
sass 1.0.0-alpha.3
Transitive dependencies
analyzer 0.29.5 0.32.1
args 0.13.7 1.4.3
async 1.13.3 2.0.7
barback 0.15.2+16
charcode 1.1.1
cli_util 0.1.3
code_transformers 0.5.1+5
collection 1.14.10
convert 2.0.1
crypto 2.0.3
csslib 0.14.4
glob 1.1.5
html 0.13.3+1
http_parser 3.1.2
isolate 0.2.3 2.0.1
logging 0.11.3+1
meta 1.1.5
mime 0.9.6+1
package_config 1.0.3
path 1.6.0
plugin 0.2.0+2
pool 1.3.5
quiver_hashcode 1.0.0
shelf 0.6.8 0.7.3+1
shelf_static 0.2.7+1
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.7
string_scanner 1.0.2
tuple 1.0.1
typed_data 1.1.5
utf 0.9.0+4
watcher 0.9.7+8
yaml 2.1.14
Dev dependencies
test >=0.12.0 <0.13.0