Replaces vars in SCSS files with package path and compiles it to .css files
Add the following lines to your
dependencies: # Only for demonstration!!!! mdl: ^1.18.0 # This is important sass_var_transformer: any transformers: - di # And this - sass_var_transformer: # Converts @mdl to ../.pub-cache/hosted/pub.dartlang.org/mdl-x.xx.x/lib mdl: package:mdl
Assume you have
Add this line to your
<head> <link rel="stylesheet" href="material.css"> </head>
If you run
The Transformer reads the SCSS-File
@mdl will be replaced with the path to your local mdl-package
@import "<your user>/.pub-cache/hosted/pub.dartlang.org/mdl-<version from pubspec>/lib/assets/themes/deep_purple-pink/material-design-lite";
SCSS-File will be compiled to .CSS
Check out this sample: GH MDL Text-Only
The sample uses a mixture between Global-Package-Style and Styles for local components!
Copyright 2017 Michael Mitterer (firstname.lastname@example.org), IT-Consulting and Development Limited, Austrian Branch Licensed under the Apache License, Version 2.0 (the "License"); you may not use this file except in compliance with the License. You may obtain a copy of the License at http://www.apache.org/licenses/LICENSE-2.0 Unless required by applicable law or agreed to in writing, software distributed under the License is distributed on an "AS IS" BASIS, WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied. See the License for the specific language governing permissions and limitations under the License.
If this plugin is helpful for you - please (Circle) me or star this repo here on GitHub
Transformer that changes vars in SASS-Files
This CHANGELOG.md was generated with Changelog for Dart
Add this to your package's pubspec.yaml file:
dependencies: sass_var_transformer: ^0.3.0
You can install packages from the command line:
$ pub get
Alternatively, your editor might support
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.3.0||Feb 28, 2017|
|0.2.0||Feb 28, 2017|
|0.1.0||Feb 28, 2017|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.
Support Dart 2 in
The SDK constraint in
pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
|Dart SDK||>=1.19.0 <2.0.0|