scanner 1.0.0

  • README.md
  • Installing
  • Versions
  • 0

scanner

version 1.0.0 build status

Port of Java's Scanner class to Dart. Works asynchronously.

Usage

Printing the contents of a file:

import 'dart:io';
import 'package:scanner/scanner.dart';

main() async {
  var file = new File.fromUri(Platform.script.resolve('../README.md'));
  var scanner = new Scanner(file.openRead());

  while (await scanner.hasNextLine()) {
    print(await scanner.nextLine());
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scanner: ^1.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scanner/scanner.dart';
  
Version Uploaded Documentation Archive
1.0.0 Mar 15, 2017 Go to the documentation of scanner 1.0.0 Download scanner 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

We analyzed this package on Sep 25, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0
  • pana: 0.12.3

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Issues and suggestions

Fix platform conflicts.

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.0.0.
 
 Because scanner depends on stream_reader any which requires SDK version >=1.19.0 <2.0.0, version solving failed.

Maintain CHANGELOG.md.

Changelog entries help clients to follow the progress in your code.

Package is getting outdated.

The package was released 79 weeks ago.

The description is too short.

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use scanner.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0