scarabei_flutter 1.0.0

  • Installing
  • Versions
  • 7

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scarabei_flutter: "^1.0.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scarabei_flutter/scarabei_flutter.dart';
        
Version Uploaded Documentation Archive
1.0.0 Jul 30, 2017 failed Download scarabei_flutter 1.0.0 archive

Analysis

We analyzed this package on Apr 9, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.46.0
  • pana: 0.10.6
  • Flutter: 0.2.9

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
1 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
34 / 100
Overall score:
Weighted score of the above. [more]
7
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Error(s) in lib/red-android/sys/scarabei_android_flutter_proxy.dart: Target of URI doesn't exist: 'package:flutter/services.dart'.

Suggestions

  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Error(s) in lib/red-android/sys/scarabei_android_flutter_proxy.dart: Target of URI doesn't exist: 'package:flutter/services.dart'.

  • Maintain CHANGELOG.md.

    Changelog entries help clients to follow the progress in your code.

  • Maintain README.md.

    Readme should inform others about your project, what it does, and how they can use it.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 53 errors 5 hints.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/red-android/sys/scarabei_android_flutter_proxy.dart: Target of URI doesn't exist: 'package:flutter/services.dart'.

    Make sure that the imported libraries are not in conflict. Error(s) in lib/red-android/scarabei_android.dart: Target of URI doesn't exist: 'package:scarabei/api-android/android.dart'.

    Similar analysis of the following files failed:

    • lib/scarabei_flutter.dart (hint)
  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use scarabei_flutter.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
flutter ^0.0.20 0.0.20
scarabei ^1.0.0 1.5.1 4.0.0
Dev dependencies
test ^0.12.0