scrapeit 0.0.1

  • Example
  • Installing
  • Versions
  • new51


A library for Dart & Flutter developers.

Created from templates made available by Stagehand under a BSD-style license.


A simple usage example:

import 'package:scrapeIt/scrapeIt.dart';

main() {
  var awesome = new Awesome();

Features and bugs

Please file feature requests and bugs at the issue tracker.



  • Initial version, created by Stagehand


import 'package:scrapeit/scrapeit.dart';

main() {
  var scrapeIt = new ScrapeIt();

1. Depend on it

Add this to your package's pubspec.yaml file:

  scrapeit: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:scrapeit/scrapeit.dart';
Version Uploaded Documentation Archive
0.0.1 Mar 6, 2018 Go to the documentation of scrapeit 0.0.1 Download scrapeit 0.0.1 archive


We analyzed this package on Mar 7, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.31.0
  • pana: 0.10.3


Describes how popular the package is relative to other packages. [more]
17 / 100
Code health derived from static analysis. [more]
76 / 100
Reflects how tidy and up-to-date the package is. [more]
99 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Primary library: package:scrapeit/scrapeit.dart with components: io.


  • Fix issues reported by dartanalyzer or dartfmt.

    dartanalyzer or dartfmt reported 1 error 1 hint.

    Strong-mode analysis of lib/src/scrapeit_base.dart failed with the following error:

    line: 6 col: 8
    Target of URI doesn't exist: 'package:http/http.dart'.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0
html ^0.13.2+2 0.13.2+2
Transitive dependencies
args 1.4.1
charcode 1.1.1
csslib 0.14.1
logging 0.11.3+1
path 1.5.1
source_span 1.4.0
utf 0.9.0+4
Dev dependencies
test ^0.12.0