screen_adaptor 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new47

screen_adaptor

A flutter screen_adaptor tool.

Getting Started

This library is designed to solve the problem of flutter screen adaptor. The default UI sketch width is 750px, based on this width, you can use this tool as follows:

// import
import 'package:screen_adaptor/screen_adaptor.dart'

// used in ui code
// 100 is the ui sketch size
Container(
  width: Fpx.to(100)
)

// 1px problem
Container(
  decoration: BoxDecoration(border: Border.all(color: Colors.blue, width: Fpx.one()))
)

// get screen width
Fpx.vw()

// get screen height
Fpx.vh()

if your ui sketch width is not 750px, such as 375px. you need set the ui width first through

Fpx.init(375)

[0.0.1] - test package publish and the function

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  screen_adaptor: ^0.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:screen_adaptor/screen_adaptor.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jan 14, 2019 Go to the documentation of screen_adaptor 0.0.1 Download screen_adaptor 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
9
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
60
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10
  • Flutter: 1.1.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use screen_adaptor.dart.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test