scribe 0.2.1

  • README.md
  • Installing
  • Versions
  • 0

scribe

A package for writing logs to the console or to a rotating file.

Usage

var server = new LoggingServer([new RotatingLoggingBackend("api.log"")]);
server.getNewTarget().bind(logger);
await server.start();

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scribe: ^0.2.1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scribe/scribe.dart';
  
Version Uploaded Documentation Archive
0.2.1 Apr 28, 2017 Go to the documentation of scribe 0.2.1 Download scribe 0.2.1 archive
0.2.0 Sep 29, 2016 Go to the documentation of scribe 0.2.0 Download scribe 0.2.0 archive
0.1.0+1 Jun 26, 2016 Go to the documentation of scribe 0.1.0+1 Download scribe 0.1.0+1 archive
0.1.0 Jun 26, 2016 Go to the documentation of scribe 0.1.0 Download scribe 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0