scripts 1.0.0-dev

  • Installing
  • Versions
  • 0


Run commands upon installing Dart packages, and more. It would be nice if all of these features were eventually integrated into the main pub executable. Until then, this will do.


$ pub global activate scripts

To use packages that integrate with scripts, you should run scripts get instead of pub get. This will run pub get, and then install package executables into a .scripts-bin directory. Then, all installed packages will have their get scripts run.

Also replace pub upgrade with scripts upgrade. This will run get scripts as well.

You can run scripts link to link executables into .scripts-bin.

Running your own Scripts

It is very likely that you want to run your own scripts during development, or upon package installation. Do as follows in your pubspec.yaml:

name: foo
# ...
  build: gcc -o foo src/
  - dart_gyp configure
  - dart_gyp build

Installed dependencies with executables will automatically be filled in to the PATH during script execution.

Then, in your project root, you can run:

$ scripts build

Available Commands


Removes the .scripts-bin directory, if present.


This script simply runs pub get, and then calls link.


Essentially an npm init for Dart. This command will run you through a series of prompts, after which a pubspec.yaml will be generated for you.


Can be used to install dependencies without having to search the Pub directory for the current version.

# Install the newest version, and apply caret syntax
$ scripts install my-package

# Install a specific version
$ scripts install my-package@^1.0.0
$ scripts install my-package@0.0.4+25
$ scripts install "my-package@>=2.0.0 <3.0.0"

# Install a Git dependency
$ scripts install my-package@git://path/to/repo.git

# Specify a commit or ref
$ scripts install my-package@git://path/to/repo.git#bleeding-edge

# Install a local package
$ scripts install my-package@path:/Users/john/Source/Dart/pkg

# Install multiple packages
$ scripts install my-package my-other-package yet-another-package

# Install to dev_dependencies
$ scripts install --dev http test my-package@git://repo#dev

# Preview new `pubspec.yaml`, without actually installing dependencies,
# or modifying the file.
$ scripts install --dry-run my-experimental-package

Creates symlinks to each dependency (in future versions, I will eliminate symlink use), and also creates executable files linked to any dependencies that export executables.


Runs clean, followed by get.

Use this package as an executable

1. Install it

You can install the package from the command line:

$ pub global activate scripts

2. Use it

The package has the following executables:

$ scripts

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  scripts: ^1.0.0-dev

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:scripts/scripts.dart';
Version Uploaded Documentation Archive
1.0.0-dev Nov 24, 2016 Go to the documentation of scripts 1.0.0-dev Download scripts 1.0.0-dev archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Dec 10, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.0.
 Because scripts depends on yamlicious ^0.0.1+1 which requires SDK version >=1.8.0 <2.0.0, version solving failed.

Health suggestions

Format lib/src/commands/clean.dart.

Run dartfmt to format lib/src/commands/clean.dart.

Format lib/src/commands/init.dart.

Run dartfmt to format lib/src/commands/init.dart.

Format lib/src/commands/link.dart.

Run dartfmt to format lib/src/commands/link.dart.

Format lib/src/commands/reset.dart.

Run dartfmt to format lib/src/commands/reset.dart.

Format lib/src/home.dart.

Run dartfmt to format lib/src/home.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use scripts.dart.

Package is pre-release. (-5 points)

Pre-release versions should be used with caution, their API may change in breaking ways.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0