scrolling_calendar 0.2.11

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 87

scrolling_calendar pipeline status

Usage demo of the scrolling calendar widget on an android device

Features

  • infinite scroll
  • tagging dates with customizable colors
  • date selection indicator
  • callback on tap with date information
  • variable start of week
  • works with both Cupertino and Material design apps

[0.2.11] - 21.07.2018

  • adjusted version constraints to support Dart 2

[0.2.10] - 29.06.2018

  • removed dependency to platform_aware

example/lib/main.dart

import 'dart:math';

import 'package:flutter/material.dart';
import 'package:scrolling_calendar/scrolling_calendar.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  static final Random random = new Random();

  static Iterable<Color> randomColors() => <Color>[]
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.red])
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.blue])
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.green]);

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Scrolling calendar',
      initialRoute: '/',
      routes: {
        '/': (BuildContext context) => new Scaffold(
            body: new ScrollingCalendar(
                firstDayOfWeek: DateTime.monday,
                onDateTapped: (DateTime date) => showDialog(
                    context: context,
                    builder: (BuildContext context) => new AlertDialog(
                          content: new Text("You tapped $date"),
                        )),
                selectedDate: new DateTime(2018, 2, 20),
                colorMarkers: (_) => randomColors()))
      },
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scrolling_calendar: ^0.2.11

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scrolling_calendar/scrolling_calendar.dart';
  
Version Uploaded Documentation Archive
0.2.11 Jul 21, 2018 Go to the documentation of scrolling_calendar 0.2.11 Download scrolling_calendar 0.2.11 archive
0.2.10 Jun 29, 2018 Go to the documentation of scrolling_calendar 0.2.10 Download scrolling_calendar 0.2.10 archive
0.2.9 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.9 Download scrolling_calendar 0.2.9 archive
0.2.8 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.8 Download scrolling_calendar 0.2.8 archive
0.2.6 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.6 Download scrolling_calendar 0.2.6 archive
0.2.5 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.5 Download scrolling_calendar 0.2.5 archive
0.2.4 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.4 Download scrolling_calendar 0.2.4 archive
0.2.0 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.0 Download scrolling_calendar 0.2.0 archive
0.1.4 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.1.4 Download scrolling_calendar 0.1.4 archive
0.1.3 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.1.3 Download scrolling_calendar 0.1.3 archive

All 17 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
75
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
87
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.24.0 <3.0.0
flutter 0.0.0
intl ^0.15.6 0.15.7
meta ^1.1.5 1.1.6
Transitive dependencies
collection 1.14.11
path 1.6.2
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test
test ^0.12.37