scrolling_calendar 0.2.6

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 37

scrolling_calendar pipeline status

Usage demo of the scrolling calendar widget on an android device

Features #

  • infinite scroll
  • tagging dates with customizable colors
  • date selection indicator
  • callback on tap with date information
  • variable start of week
  • works with both Cupertino and Material design apps

[0.0.1] - TODO: Add release date.

  • TODO: Describe initial release.

example/lib/main.dart

import 'dart:math';

import 'package:flutter/material.dart';
import 'package:scrolling_calendar/scrolling_calendar.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  static final Random random = new Random();

  static Iterable<Color> randomColors() => <Color>[]
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.red])
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.blue])
    ..addAll(random.nextBool() ? <Color>[] : <Color>[Colors.green]);

  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Scrolling calendar',
      initialRoute: '/',
      routes: {
        '/': (BuildContext context) => new Scaffold(
            body: new ScrollingCalendar(
                firstDayOfWeek: DateTime.monday,
                onDateTapped: (DateTime date) => showDialog(
                    context: context,
                    builder: (BuildContext context) => new AlertDialog(
                          content: new Text("You tapped $date"),
                        )),
                selectedDate: new DateTime(2018, 2, 20),
                colorMarkers: (_) => randomColors()))
      },
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  scrolling_calendar: ^0.2.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:scrolling_calendar/scrolling_calendar.dart';
  
Version Uploaded Documentation Archive
0.2.12 Jan 9, 2019 Go to the documentation of scrolling_calendar 0.2.12 Download scrolling_calendar 0.2.12 archive
0.2.11 Jul 21, 2018 Go to the documentation of scrolling_calendar 0.2.11 Download scrolling_calendar 0.2.11 archive
0.2.10 Jun 29, 2018 Go to the documentation of scrolling_calendar 0.2.10 Download scrolling_calendar 0.2.10 archive
0.2.9 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.9 Download scrolling_calendar 0.2.9 archive
0.2.8 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.8 Download scrolling_calendar 0.2.8 archive
0.2.6 Jun 28, 2018 Go to the documentation of scrolling_calendar 0.2.6 Download scrolling_calendar 0.2.6 archive
0.2.5 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.5 Download scrolling_calendar 0.2.5 archive
0.2.4 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.4 Download scrolling_calendar 0.2.4 archive
0.2.1 Jan 9, 2019 Go to the documentation of scrolling_calendar 0.2.1 Download scrolling_calendar 0.2.1 archive
0.2.0 Jun 25, 2018 Go to the documentation of scrolling_calendar 0.2.0 Download scrolling_calendar 0.2.0 archive

All 19 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
74
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
37
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Running dartdoc failed with the following output:


Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0