secure_string 2.0.0

  • README.md
  • Installing
  • Versions
  • 28

Secure string

This is a cryptographically secure random string generator based on dart:math.Random.secure.

Usage:

Create an instance with new SecureString():

SecureString secureString = new SecureString();

Then generate random strings with it:

String randomString = secureString.generate(length: 512);

The length defaults to 1024 if no length is specified.

Custom character lists

To specify a list of allowed characters, use the named parameter charList:

String randomBinaryString = secureString.generate(charList: ["0", "1"]);

The list defaults to hexadecimal characters (0-f).

Insecure string:

To create insecure random strings: use new SecureString(string: false) instead of new SecureString(). You can also specify a seed using new SecureString(string: false, seed: 2) (replacing 2 with your seed).

Trivia:

This library was made in spite of a library already existing due to two reasons:

  • That library did not have functionality for Random.secure.
  • That library was licensed under the BSD 3 clause license.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  secure_string: ^2.0.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:secure_string/secure_string.dart';
  
Version Uploaded Documentation Archive
2.0.0 Jul 29, 2017 Go to the documentation of secure_string 2.0.0 Download secure_string 2.0.0 archive
1.1.0 Jul 29, 2017 Go to the documentation of secure_string 1.1.0 Download secure_string 1.1.0 archive
1.0.0 Jul 29, 2017 Go to the documentation of secure_string 1.0.0 Download secure_string 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
56
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
28
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >1.24.0 <2.0.0