semantic_ui_angular_dart 0.1.6

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

semantic_ui_angular_dart

Semantic UI for Angular Dart.

Demo

Pub

Dartdocs

Setup

pubspec.yaml:

dependencies:
  semantic_ui_angular_dart: 

HTML:

<link rel="stylesheet" href="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.6/semantic.min.css"/>
<!-- Calendar -->
<link rel="stylesheet" href="packages/semantic_ui_angular_dart/calendar.min.css"/>

<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/jquery/1.12.4/jquery.min.js"></script>
<script type="text/javascript" src="https://cdnjs.cloudflare.com/ajax/libs/semantic-ui/2.2.6/semantic.min.js"></script>
<!-- Calendar -->
<script type="text/javascript" src="packages/semantic_ui_angular_dart/calendar.min.js"></script>

Dart:

import 'package:semantic_ui_angular_dart/semantic_ui_angular_dart.dart';

Usage

Calendar

[WIP]

https://github.com/mdehoog/Semantic-UI-Calendar

HTML:

<div [semantic_ui_calendar]="startDateSettings" [(ngModel)]="startDate" class="ui calendar">
    <div class="ui input left icon">
        <i class="calendar icon"></i>
        <input type="text" placeholder="Start date"/>
    </div>
</div>

Dart:

var startDateSettings = { 'type': 'date' };
var startDate = DateTime.parse('2016-10-01');

NOTE: Currently does not work with select.

HTML:

<div semantic_ui_dropdown [(ngModel)]="gender" class="ui dropdown">
    <input type="hidden" name="gender">
    <i class="dropdown icon"></i>
    <div class="default text">Gender</div>
    <div class="menu">
        <div class="item" data-value="male">Male</div>
        <div class="item" data-value="female">Female</div>
    </div>
</div>

Dart:

var gender;

Progress

HTML:

<div (semantic_ui_progress)="initProgress($event)" [percent]="30" class="ui progress">
    <div class="bar">
        <div class="progress"></div>
    </div>
    <div class="label">Uploading Files</div>
</div>

Dart:

Progress progress;

initProgress(Progress progress) {
  this.progress = progress;
}

HTML:

<div (semantic_ui_sidebar)="initSidebar($event)" class="ui sidebar">
    ...
</div>
<div class="pusher">
    <div class="ui container">
        <button (click)="onToggleSidebarButtonClicked()" class="ui basic icon button">
            <i class="large content icon"></i>
        </button>
        ...
    </div>
</div>

Dart:

Sidebar sidebar;

onToggleSidebarButtonClicked() {
    sidebar.toggle();
}

initSidebar(Sidebar sidebar) {
    this.sidebar = sidebar;
}

Tab

HTML:

<div semantic_ui_tab class="ui tabular menu">
    <div class="active item" data-tab="tab-1">Tab 1</div>
    <div class="item" data-tab="tab-2">Tab 2</div>
    <div class="item" data-tab="tab-3">Tab 3</div>
</div>
<div class="ui active tab" data-tab="tab-1">
    <p>
        ...
    </p>
</div>
<div class="ui tab" data-tab="tab-2">
    <p>
        ...
    </p>
</div>
<div class="ui tab" data-tab="tab-3">
    <p>
        ...
    </p>
</div>

Changelog

0.1.6

  • Updated semantic_ui_calendar directive to support 'startCalendar' and 'endCalendar' settings.

0.1.5

  • Added semantic_ui_progress directive.

0.1.4

  • Added semantic_ui_tab directive.

0.1.3

  • Added semantic_ui_dropdown directive.

0.1.2

  • Fix for sidebar pusher issue.

0.1.0

  • Added directive namespace.
  • Added semantic_ui_calendar directive.

0.0.5

  • Added SEMANTIC_UI_DIRECTIVES.
  • Updated README.

0.0.4

  • Updated README.

0.0.3

  • Fixed error in pubspec.yaml.

0.0.2

  • Fix for 'Could not find Directive/Pipe entry for name' error.

0.0.1

  • Initial version, created by Stagehand

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  semantic_ui_angular_dart: ^0.1.6

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:semantic_ui_angular_dart/semantic_ui_angular_dart.dart';
  
Version Uploaded Documentation Archive
0.1.6 Nov 30, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.6 Download semantic_ui_angular_dart 0.1.6 archive
0.1.5 Nov 13, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.5 Download semantic_ui_angular_dart 0.1.5 archive
0.1.4 Nov 8, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.4 Download semantic_ui_angular_dart 0.1.4 archive
0.1.3 Nov 8, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.3 Download semantic_ui_angular_dart 0.1.3 archive
0.1.2 Nov 7, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.2 Download semantic_ui_angular_dart 0.1.2 archive
0.1.0 Nov 7, 2016 Go to the documentation of semantic_ui_angular_dart 0.1.0 Download semantic_ui_angular_dart 0.1.0 archive
0.0.5 Nov 7, 2016 Go to the documentation of semantic_ui_angular_dart 0.0.5 Download semantic_ui_angular_dart 0.0.5 archive
0.0.4 Nov 6, 2016 Go to the documentation of semantic_ui_angular_dart 0.0.4 Download semantic_ui_angular_dart 0.0.4 archive
0.0.3 Nov 6, 2016 Go to the documentation of semantic_ui_angular_dart 0.0.3 Download semantic_ui_angular_dart 0.0.3 archive
0.0.1 Nov 6, 2016 Go to the documentation of semantic_ui_angular_dart 0.0.1 Download semantic_ui_angular_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0