sentry_client 4.1.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 78

pub Build Status codecov documentation

The Dart library for sending data to the Sentry server.

Usage in browser:

var client = new SentryClientBrowser(
  SentryDsn.fromString('https://123456789abcdef123456789abcdef12@sentry.local/1')
);

client.write(new SentryPacket());

Usage on server:

var client = new SentryClientServer(
  SentryDsn.fromString('https://123456789abcdef123456789abcdef12@sentry.local/1')
);

client.write(new SentryPacket());

Changelog

4.1.0

  • Update the linter rules & remove nulls from the request

4.0.4

  • Prepare for dart 2.0
  • Remove 1.21.1 checks
  • Change SentrySDK (lib/api_data/sentry_sdk.dart) for new versions!

4.0.3

  • Correct the build shield

4.0.2

  • The integration with travis-ci.com and codecov.io

4.0.1

  • The authors format was fixed

4.0.0

  • The first open-source version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  sentry_client: "^4.1.0"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:sentry_client/sentry_client.dart';
  
Version Uploaded Documentation Archive
4.1.0 Feb 11, 2018 Go to the documentation of sentry_client 4.1.0 Download sentry_client 4.1.0 archive
4.0.4 Feb 11, 2018 Go to the documentation of sentry_client 4.0.4 Download sentry_client 4.0.4 archive
4.0.3 Aug 13, 2017 Go to the documentation of sentry_client 4.0.3 Download sentry_client 4.0.3 archive
4.0.1 Aug 9, 2017 Go to the documentation of sentry_client 4.0.1 Download sentry_client 4.0.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
58 / 100
Health:
Code health derived from static analysis. [more]
97 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
78
Learn more about scoring.

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:sentry_client/sentry_client.dart.

Suggestions

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 15 hints.

    Run dartfmt to format lib/api_data/sentry_exception.dart.

    Run dartfmt to format lib/api_data/sentry_packet.dart.

    Similar analysis of the following files failed:

    • lib/api_data/sentry_request.dart (hint)
    • lib/api_data/sentry_sdk.dart (hint)
    • lib/api_data/sentry_stacktrace.dart (hint)
    • lib/api_data/sentry_stacktrace_frame.dart (hint)
    • lib/api_data/sentry_user.dart (hint)
    • lib/http_adaptors/http_adapter.dart (hint)
    • lib/http_adaptors/http_adapter_browser.dart (hint)
    • lib/http_adaptors/http_adapter_server.dart (hint)
    • lib/sentry_client.dart (hint)
    • lib/sentry_client_browser.dart (hint)
    • lib/sentry_client_server.dart (hint)
    • lib/sentry_dsn.dart (hint)
  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use sentry_client.dart.

  • Use analysis_options.yaml.

    Rename old .analysis_options file to analysis_options.yaml.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.21.1 <2.0.0
uuid ^0.5.0 0.5.3 1.0.0
Transitive dependencies
charcode 1.1.1
collection 1.14.10
convert 2.0.1
crypto 2.0.5
typed_data 1.1.5
Dev dependencies
coverage >=0.7.9 <1.0.0
dart_dev ^1.7.2
dart_style ^1.0.7
mockito ^2.0.0
quiver >=0.21.4 <1.0.0
test ^0.12.15