serve 1.0.4

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

serve

CLI to serves static files in a directory. Simpler to Python's python -m SimpleHTTPServer.

Installing

pub global activate serve

Serve files in current directory

serve

This command by default serves content of current directory on port 8080 and host 0.0.0.0.

Configure host and port

Use --host (abbreviation -h) and --port (abbreviation -p) to serve on desired host and port.

serve -h localhost -p 8081

Serve content of specific directory

Use --dir (abbreviated as -d) to serve contents of a desired directory.

serve -d /home/myname/mysite

Serve at a given base path

Use --base-path (abbreviated as -b) to serve contents with desired base path.

serve -b /myblog

More features to come!

Changelog

1.0.3

  • Respects index.html

1.0.2

  • HTTPS support

1.0.1

  • Serve

1.0.0

  • Args

Use this package as an executable

1. Install it

You can install the package from the command line:


$ pub global activate serve

2. Use it

The package has the following executables:


$ serve

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  serve: ^1.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:serve/serve.dart';
  
Version Uploaded Documentation Archive
1.0.4 Feb 2, 2018 Go to the documentation of serve 1.0.4 Download serve 1.0.4 archive
1.0.3 Jan 24, 2018 Go to the documentation of serve 1.0.3 Download serve 1.0.3 archive
1.0.2 Jan 16, 2018 Go to the documentation of serve 1.0.2 Download serve 1.0.2 archive
1.0.1 Jan 15, 2018 Go to the documentation of serve 1.0.1 Download serve 1.0.1 archive
1.0.0 Jan 15, 2018 Go to the documentation of serve 1.0.0 Download serve 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.20.1 <2.0.0