shadow_dom 0.10.0

  • README.md
  • Installing
  • Versions
  • 23

Shadow DOM polyfill - deprecated

Deprecated please use http://pub.dartlang.org/packages/web_components instead for polyfilling Shadow DOM. Instructions are available at that link.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shadow_dom: ^0.10.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

Version Uploaded Documentation Archive
0.10.0 May 6, 2014 Go to the documentation of shadow_dom 0.10.0 Download shadow_dom 0.10.0 archive
0.9.2 Jan 31, 2014 Go to the documentation of shadow_dom 0.9.2 Download shadow_dom 0.9.2 archive
0.9.1 Nov 22, 2013 Go to the documentation of shadow_dom 0.9.1 Download shadow_dom 0.9.1 archive
0.9.0 Nov 6, 2013 Go to the documentation of shadow_dom 0.9.0 Download shadow_dom 0.9.0 archive
0.8.10+4 Nov 5, 2013 Go to the documentation of shadow_dom 0.8.10+4 Download shadow_dom 0.8.10+4 archive
0.8.10+3 Nov 4, 2013 Go to the documentation of shadow_dom 0.8.10+3 Download shadow_dom 0.8.10+3 archive
0.8.10 Nov 1, 2013 Go to the documentation of shadow_dom 0.8.10 Download shadow_dom 0.8.10 archive
0.8.9 Oct 31, 2013 Go to the documentation of shadow_dom 0.8.9 Download shadow_dom 0.8.9 archive
0.8.8 Oct 30, 2013 Go to the documentation of shadow_dom 0.8.8 Download shadow_dom 0.8.8 archive
0.8.7 Oct 28, 2013 Go to the documentation of shadow_dom 0.8.7 Download shadow_dom 0.8.7 archive

All 41 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
46
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
23
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.2.0-dev.3.0 <2.0.0