share_extend 1.0.3

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 92

ShareExtend #

调用系统分享的Flutter组件,支持分享文本,图片和文件

安装 #

dependencies:
  share_extend: "^1.0.3"

导入 #

import 'package:share_extend/share_extend.dart';

使用 #


//分享文本
ShareExtend.share("share text", "text");

//分享图片 (例子中使用了一个image_picker的插件来实现图片的选择)
File f =
    await ImagePicker.pickImage(source: ImageSource.gallery);
ShareExtend.share(f.path, "image");

//分享文件
Directory dir = await getApplicationDocumentsDirectory();
File testFile = new File("${dir.path}/flutter/test.txt");
if (!await testFile.exists()) {
  await testFile.create(recursive: true);
  testFile.writeAsStringSync("test for share documents file");
}
ShareExtend.share(testFile.path, "file"); 

0.0.1 #

  • TODO: Describe initial release.

example/README.md

share_extend_example #

Demonstrates how to use the share_extend plugin.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  share_extend: ^1.0.3

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:share_extend/share_extend.dart';
  
Version Uploaded Documentation Archive
1.0.3 Dec 17, 2018 Go to the documentation of share_extend 1.0.3 Download share_extend 1.0.3 archive
1.0.2 Dec 3, 2018 Go to the documentation of share_extend 1.0.2 Download share_extend 1.0.2 archive
1.0.1 Oct 28, 2018 Go to the documentation of share_extend 1.0.1 Download share_extend 1.0.1 archive
1.0.0 Oct 28, 2018 Go to the documentation of share_extend 1.0.0 Download share_extend 1.0.0 archive
0.0.1 Oct 9, 2018 Go to the documentation of share_extend 0.0.1 Download share_extend 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
83
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
92
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.28.0 <3.0.0
flutter 0.0.0
meta ^1.0.5 1.1.6 1.1.7
Transitive dependencies
collection 1.14.11
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8