shelf 0.0.0-dev+1

  • README.md
  • Installing
  • Versions
  • 47

#Shelf

Web Server Middleware for Dart

Build Status

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shelf: ^0.0.0-dev+1

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shelf/shelf.dart';
  
Version Uploaded Documentation Archive
0.7.3+3 Jul 16, 2018 Go to the documentation of shelf 0.7.3+3 Download shelf 0.7.3+3 archive
0.7.3+2 Jul 10, 2018 Go to the documentation of shelf 0.7.3+2 Download shelf 0.7.3+2 archive
0.7.3+1 May 22, 2018 Go to the documentation of shelf 0.7.3+1 Download shelf 0.7.3+1 archive
0.7.3 May 2, 2018 Go to the documentation of shelf 0.7.3 Download shelf 0.7.3 archive
0.7.2 Jan 4, 2018 Go to the documentation of shelf 0.7.2 Download shelf 0.7.2 archive
0.7.1 Oct 26, 2017 Go to the documentation of shelf 0.7.1 Download shelf 0.7.1 archive
0.7.0 Aug 29, 2017 Go to the documentation of shelf 0.7.0 Download shelf 0.7.0 archive
0.6.8 Jun 23, 2017 Go to the documentation of shelf 0.6.8 Download shelf 0.6.8 archive
0.6.7+2 Dec 6, 2016 Go to the documentation of shelf 0.6.7+2 Download shelf 0.6.7+2 archive
0.6.7+1 Oct 26, 2016 Go to the documentation of shelf 0.6.7+1 Download shelf 0.6.7+1 archive

All 57 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
95
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0