Memcache (appengine flavour) oauth token persistence
Please file feature requests and bugs at the issue tracker.
Add this to your package's pubspec.yaml file:
dependencies: shelf_oauth_memcache: ^0.3.7
You can install packages from the command line:
$ pub get
$ flutter packages get
Alternatively, your editor might support
pub get or
flutter packages get.
Check the docs for your editor to learn more.
Now in your Dart code, you can use:
|0.3.7||Apr 10, 2016|
|0.3.6||Jan 6, 2016|
|0.3.5||Aug 12, 2015|
|0.3.4||Jul 1, 2015|
|0.3.3||Jun 25, 2015|
|0.3.2||Jun 25, 2015|
|0.3.1||Jun 25, 2015|
|0.3.0||Jun 23, 2015|
|0.2.1+1||Mar 14, 2015|
|0.2.1||Mar 1, 2015|
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
We analyzed this package on Jul 20, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:
Detected platforms: Flutter, other
lib/src/oauth2_token_store_impl.dart failed with 2 errors, 3 hints:
line 22 col 42: The argument type '(DateTime) → Null' can't be assigned to the parameter type '(dynamic) → dynamic'.
line 33 col 11: The return type 'Option' isn't a 'FutureOr<Option<OAuth2TokenPair>>', as defined by anonymous closure.
line 23 col 13: The value of the local variable 'tokenExpiration' isn't used.
line 26 col 39: 'JSON' is deprecated and shouldn't be used.
line 34 col 59: 'JSON' is deprecated and shouldn't be used.
lib/src/oauth2_csrf_state_store_impl.dart failed with 1 error, 2 hints:
line 27 col 11: The return type 'Option' isn't a 'FutureOr<Option<OAuth2State>>', as defined by anonymous closure.
line 22 col 28: 'JSON' is deprecated and shouldn't be used.
line 27 col 57: 'JSON' is deprecated and shouldn't be used.
Support Dart 2 in
The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.
Package is too old.
The package was released more than two years ago.
The description is too short.
Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.
Package is pre-v1 release.
While there is nothing inherently wrong with versions of
0.*.*, it usually means that the author is still experimenting with the general direction of the API.
Maintain an example.
Create a short demo in the
example/ directory to show how to use this package. Common file name patterns include:
example.dart or you could also use
|Dart SDK||>=1.8.0 <2.0.0|