shelf_proxy 0.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 38

Build Status

Shelf handler to proxy requests to another web server.

Useful if you want to send a subset of requests to another HTTP endpoint, for instance pub serve.

See example/example_server.dart for a usage demonstration.

0.0.2

  • Updated README.md and doc comments on createProxyHandler.

  • Added an example.

0.0.1

  • First release.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shelf_proxy: ^0.0.2

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shelf_proxy/shelf_proxy.dart';
  
Version Uploaded Documentation Archive
0.1.0+5 Aug 17, 2018 Go to the documentation of shelf_proxy 0.1.0+5 Download shelf_proxy 0.1.0+5 archive
0.1.0+4 May 9, 2016 Go to the documentation of shelf_proxy 0.1.0+4 Download shelf_proxy 0.1.0+4 archive
0.1.0+3 Feb 2, 2016 Go to the documentation of shelf_proxy 0.1.0+3 Download shelf_proxy 0.1.0+3 archive
0.1.0+2 Mar 5, 2015 Go to the documentation of shelf_proxy 0.1.0+2 Download shelf_proxy 0.1.0+2 archive
0.1.0+1 Jul 31, 2014 Go to the documentation of shelf_proxy 0.1.0+1 Download shelf_proxy 0.1.0+1 archive
0.1.0 Jul 3, 2014 Go to the documentation of shelf_proxy 0.1.0 Download shelf_proxy 0.1.0 archive
0.0.2 Jul 2, 2014 Go to the documentation of shelf_proxy 0.0.2 Download shelf_proxy 0.0.2 archive
0.0.1 Jul 1, 2014 Go to the documentation of shelf_proxy 0.0.1 Download shelf_proxy 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
75
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
38
Learn more about scoring.

This package version is not analyzed, because it is more than two years old. Check the latest stable version for its analysis.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.0.0 <2.0.0