shelf_static 0.2.5

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 47

shelf_static is a Handler for the Dart shelf package.

Build Status

Example

import 'package:shelf/shelf_io.dart' as io;
import 'package:shelf_static/shelf_static.dart';

void main() {
  var handler = createStaticHandler('example/files', 
      defaultDocument: 'index.html');

  io.serve(handler, 'localhost', 8080);
}

0.2.5

  • Add an optional contentTypeResolver argument to createStaticHandler.

0.2.4

  • Add support for "sniffing" the content of the file for the content-type via an optional useHeaderBytesForContentType argument on createStaticHandler.

0.2.3+4

  • Support http_parser 3.0.0.

0.2.3+3

  • Support shelf 0.7.0.

0.2.3+2

  • Support http_parser 2.0.0.

0.2.3+1

  • Support http_parser 1.0.0.

0.2.3

  • Added listDirectories argument to createStaticHandler.

0.2.2

  • Bumped up minimum SDK to 1.7.0.

  • Added support for shelf 0.6.0.

0.2.1

  • Removed Uri format checks now that the core libraries is more strict.

0.2.0

  • Removed deprecated getHandler.

  • Send correct mime type for default document.

0.1.4+6

  • Updated development dependencies.

0.1.4+5

  • Handle differences in resolution between DateTime and HTTP date format.

0.1.4+4

  • Using latest shelf. Cleaned up test code by using new features.

0.1.4

  • Added named (optional) defaultDocument argument to createStaticHandler.

0.1.3

  • createStaticHandler added serveFilesOutsidePath optional parameter.

0.1.2

  • The preferred top-level method is now createStaticHandler. getHandler is deprecated.
  • Set content-type header if the mime type of the requested file can be determined from the file extension.
  • Respond with 304-Not modified against IF-MODIFIED-SINCE request header.
  • Better error when provided a non-existent fileSystemPath.
  • Added example/example_server.dart.

0.1.1+1

  • Removed work around for issue.

0.1.1

  • Correctly handle requests when not hosted at the root of a site.
  • Send last-modified header.
  • Work around known issue with HTTP date formatting.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shelf_static: ^0.2.5

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:shelf_static/shelf_static.dart';
  
Version Uploaded Documentation Archive
0.2.8 Jul 12, 2018 Go to the documentation of shelf_static 0.2.8 Download shelf_static 0.2.8 archive
0.2.7+1 May 22, 2018 Go to the documentation of shelf_static 0.2.7+1 Download shelf_static 0.2.7+1 archive
0.2.7 Jan 4, 2018 Go to the documentation of shelf_static 0.2.7 Download shelf_static 0.2.7 archive
0.2.6 Oct 18, 2017 Go to the documentation of shelf_static 0.2.6 Download shelf_static 0.2.6 archive
0.2.5 Jul 7, 2017 Go to the documentation of shelf_static 0.2.5 Download shelf_static 0.2.5 archive
0.2.4 Jul 6, 2016 Go to the documentation of shelf_static 0.2.4 Download shelf_static 0.2.4 archive
0.2.3+4 May 5, 2016 Go to the documentation of shelf_static 0.2.3+4 Download shelf_static 0.2.3+4 archive
0.2.3+3 Feb 2, 2016 Go to the documentation of shelf_static 0.2.3+3 Download shelf_static 0.2.3+3 archive
0.2.3+2 Dec 14, 2015 Go to the documentation of shelf_static 0.2.3+2 Download shelf_static 0.2.3+2 archive
0.2.3+1 Aug 26, 2015 Go to the documentation of shelf_static 0.2.3+1 Download shelf_static 0.2.3+1 archive

All 27 versions...

Popularity:
Describes how popular the package is relative to other packages. [more]
93
Health:
Code health derived from static analysis. [more]
--
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
--
Overall:
Weighted score of the above. [more]
47
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Analysis issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Maintenance issues and suggestions

Running dartdoc failed. (-10 points)

Make sure dartdoc runs without any issues.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.7.0 <2.0.0