shelf_test_handler 1.0.2

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 67

A shelf handler that makes it easy to test HTTP interactions, especially when multiple different HTTP requests are expected in a particular sequence.

You can construct a ShelfTestHandler directly, but most users will probably want to use the ShelfTestServer instead. This wraps the handler in a simple HTTP server, whose URL can be passed to client code.

import 'package:shelf/shelf.dart' as shelf;
import 'package:shelf_test_handler/shelf_test_handler.dart';
import 'package:test/test.dart';

import 'package:my_package/my_package.dart';

void main() {
  test("client performs protocol handshake", () async {
    // This is just a utility class that starts a server for a ShelfTestHandler.
    var server = new ShelfTestServer();

    // Asserts that the client will make a GET request to /token.
    server.handler.expect("GET", "/token", (request) async {
      // This handles the GET /token request.
      var body = JSON.parse(await request.readAsString());

      // Any failures in this handler will cause the test to fail, so it's safe
      // to make assertions.
      expect(body, containsPair("id", "my_package_id"));
      expect(body, containsPair("secret", "123abc"));

      return new shelf.Response.ok(JSON.encode({"token": "a1b2c3"}),
          headers: {"content-type": "application/json"});
    });

    // Requests made against `server.url` will be handled by the handlers we
    // declare.
    var myPackage = new MyPackage(server.url);

    // If the client makes any unexpected requests, the test will fail.
    await myPackage.performHandshake();
  });
}

1.0.2

  • Support test 1.x.x.

1.0.1

  • Support latest pkg/shelf.

1.0.0

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shelf_test_handler: "^1.0.2"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:shelf_test_handler/shelf_test_handler.dart';
  
Version Uploaded Documentation Archive
1.0.2 Jun 15, 2018 Go to the documentation of shelf_test_handler 1.0.2 Download shelf_test_handler 1.0.2 archive
1.0.1 Aug 30, 2017 Go to the documentation of shelf_test_handler 1.0.1 Download shelf_test_handler 1.0.1 archive
1.0.0 Jun 7, 2017 Go to the documentation of shelf_test_handler 1.0.0 Download shelf_test_handler 1.0.0 archive
1.0.0-rc.1 May 23, 2017 Go to the documentation of shelf_test_handler 1.0.0-rc.1 Download shelf_test_handler 1.0.0-rc.1 archive

Analysis

We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
34 / 100
Health:
Code health derived from static analysis. [more]
99 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100 / 100
Overall score:
Weighted score of the above. [more]
67
Learn more about scoring.

Platforms

Detected platforms: Flutter, other

Primary library: package:shelf_test_handler/shelf_test_handler.dart with components: io, isolate.

Suggestions

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use shelf_test_handler.dart.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 hint.

    Strong-mode analysis of lib/src/handler.dart gave the following hint:

    line: 64 col: 3
    This function declares a return type of 'FutureOr<Response>', but doesn't end with a return statement.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0
http_multi_server ^2.0.0 2.0.5
shelf >=0.6.0 <0.8.0 0.7.3+1
test >=0.12.19 <2.0.0 1.0.0
Transitive dependencies
analyzer 0.32.1
args 1.4.3
async 2.0.7
boolean_selector 1.0.3
charcode 1.1.1
collection 1.14.10
convert 2.0.1
crypto 2.0.5
csslib 0.14.4
front_end 0.1.1
glob 1.1.5
html 0.13.3+1
http_parser 3.1.2
io 0.3.2+1
js 0.6.1
json_rpc_2 2.0.8
kernel 0.3.1
logging 0.11.3+1
matcher 0.12.3
meta 1.1.5
mime 0.9.6+1
multi_server_socket 1.0.1
node_preamble 1.4.2
package_config 1.0.3
package_resolver 1.0.3
path 1.6.1
plugin 0.2.0+2
pool 1.3.5
pub_semver 1.4.1
shelf_packages_handler 1.0.3
shelf_static 0.2.7+1
source_map_stack_trace 1.1.4
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
stream_channel 1.6.7+1
string_scanner 1.0.2
term_glyph 1.0.0
typed_data 1.1.5
utf 0.9.0+4
vm_service_client 0.2.4+3
watcher 0.9.7+8
web_socket_channel 1.0.8
yaml 2.1.14
Dev dependencies
http ^0.11.3 0.11.3+16
shelf_web_socket ^0.2.1 0.2.2+2