shortbow 0.0.1

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • new44

shortbow 🏹

This library is incomplete and a work in-progress.

A lightweight 2D game utility library built for usability.

It is inspired by the following projects:

Technical Overview

Libraries

Shortbow is a collection of libraries to facilitate the creation of your next awesome 2D web-based game, written in Dart, a modern object-oriented programming language. Some of the elements of this library are more specific to writing a simple game engine, and others are more related to game mechanics or common patterns needed.

geometry.dart

Math functions and value-type primitives used in the engine.

mechanics.dart

Different mechanics-related APIs, such as dice, decks of cards, and more.

painting.dart

Low-level 2D painting library that abstracts away platform-specific APIs.

v0.0.1

  • Initial release with Point, Rectangle, Color, and DiceRoller.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  shortbow: "^0.0.1"

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


      import 'package:shortbow/geometry.dart';

      import 'package:shortbow/mechanics.dart';

      import 'package:shortbow/painting.dart';
  
Version Uploaded Documentation Archive
0.0.1 Jul 7, 2018 Go to the documentation of shortbow 0.0.1 Download shortbow 0.0.1 archive

Analysis

We analyzed this package on Jul 13, 2018, and provided a score, details, and suggestions below. Analysis was completed with status tool failures using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3

Scores

Popularity:
Describes how popular the package is relative to other packages. [more]
0 / 100
Health:
Code health derived from static analysis. [more]
100 / 100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
72 / 100
Overall score:
Weighted score of the above. [more]
44
Learn more about scoring.

Platforms

Detected platforms: unsure

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Suggestions

  • Fix dependencies in pubspec.yaml.

    Running pub upgrade failed with the following output:

    ERR: The current Dart SDK version is 2.0.0-dev.63.0.
     
     Because shortbow requires SDK version >=2.0.0-dev.67.0 <3.0.0, version solving failed.
    
  • Fix platform conflicts.

    Error(s) prevent platform classification:

    Fix dependencies in pubspec.yaml.

  • Running dartdoc failed.

    Make sure dartdoc runs without any issues.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use shortbow.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.67.0 <3.0.0