shortbow 0.2.0

  • Installing
  • Versions
  • 44

shortbow 🏹

This library is incomplete and a work in-progress.

A lightweight 2D game utility library built for usability.

Build Status

It is inspired by the following projects:

Technical Overview


Shortbow is a collection of libraries to facilitate the creation of your next awesome 2D web-based game, written in Dart, a modern object-oriented programming language. Some of the elements of this library are more specific to writing a simple game engine, and others are more related to game mechanics or common patterns needed.


Common useful methods when using this library (and used by this library).


Drawing libraries and classes that abstract away platform-specific APIs.


Math functions and value-type primitives useful in games.


Different mechanics-related APIs, such as dice, decks of cards, and more.


  • Renamed the geometry.dart library to math.dart.
  • Added common.dart with hash functions and assertionsEnabled.


  • Renamed Point -> Vector.
  • Renamed the painting.dart library to drawing.dart.
  • Added Input, InputController, Button, ButtonController.
  • Some other small fixes or improvements that aren't significant.


  • Initial release with Point, Rectangle, Color, and DiceRoller.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  shortbow: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:shortbow/common.dart';
import 'package:shortbow/math.dart';
import 'package:shortbow/mechanics.dart';
import 'package:shortbow/painting.dart';
Version Uploaded Documentation Archive
0.2.0 Sep 4, 2018 Go to the documentation of shortbow 0.2.0 Download shortbow 0.2.0 archive
0.1.0 Aug 31, 2018 Go to the documentation of shortbow 0.1.0 Download shortbow 0.1.0 archive
0.0.1 Jul 7, 2018 Go to the documentation of shortbow 0.0.1 Download shortbow 0.0.1 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Jan 15, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.10


Detected platforms: Flutter, web, other

No platform restriction found in libraries.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use shortbow.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.67.0 <3.0.0
meta ^1.1.5 1.1.7
Dev dependencies
build_runner ^0.9.1
build_test ^0.10.3
build_web_compilers ^0.4.0+4
test ^1.2.0