signal_dart 0.0.4

  • Installing
  • Versions
  • 51


A package to help use SignalR JS client with Dart


//Equivalent to var hc = $.hubConnection(url,options);
HubConnection hc = new HubConnection(url:'http://localhost:55780/signalr');
//Equivalent to $.connection.testHub on default local server
HubProxy proxy = hc.createHubProxy('testHub');
 Equivalent to
 proxy.on('broadcastMessage', function (name, message) {
proxy.on('broadcastMessage', (String name,String message) {
    document.querySelector('#messageList').appendHtml('<li>' + name + ' - ' + message + '</li>');

1. Depend on it

Add this to your package's pubspec.yaml file:

  signal_dart: "^0.0.4"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:signal_dart/signal_dart.dart';
Version Uploaded Documentation Archive
0.0.4 Mar 3, 2016 Go to the documentation of signal_dart 0.0.4 Download signal_dart 0.0.4 archive
0.0.3 Dec 17, 2014 Go to the documentation of signal_dart 0.0.3 Download signal_dart 0.0.3 archive
0.0.1 Jul 5, 2014 Go to the documentation of signal_dart 0.0.1 Download signal_dart 0.0.1 archive


This feature is new.
We welcome feedback.
More details: scoring.

We analyzed this package, and provided a score, details, and suggestions below.

  • completed on Feb 3, 2018
  • Dart: 2.0.0-dev.20.0
  • pana: 0.10.1


Describes how popular the package is relative to other packages. [more]
44 / 100
Code health derived from static analysis. [more]
92 / 100
Reflects how tidy and up-to-date the package is. [more]
6 / 100
Overall score:
Weighted score of the above. [more]


Detected platforms: web, other

Primary library: package:signal_dart/signal_dart.dart with components: js.


  • Maintain

    Changelog entries help clients to follow the progress in your code.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use signal_dart.dart.


Package Constraint Resolved Available
Dev dependencies
browser any