signal_dart 0.0.4

  • README.md
  • Installing
  • Versions
  • 2

SignalDart

A package to help use SignalR JS client with Dart

###Example###

//Equivalent to var hc = $.hubConnection(url,options);
HubConnection hc = new HubConnection(url:'http://localhost:55780/signalr');
//Equivalent to $.connection.testHub on default local server
HubProxy proxy = hc.createHubProxy('testHub');
/*
 Equivalent to
 proxy.on('broadcastMessage', function (name, message) {
             //...
 });
 */
proxy.on('broadcastMessage', (String name,String message) {
    document.querySelector('#messageList').appendHtml('<li>' + name + ' - ' + message + '</li>');
  });

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  signal_dart: ^0.0.4

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:signal_dart/signal_dart.dart';
  
Version Uploaded Documentation Archive
0.0.4 Mar 3, 2016 Go to the documentation of signal_dart 0.0.4 Download signal_dart 0.0.4 archive
0.0.3 Dec 17, 2014 Go to the documentation of signal_dart 0.0.3 Download signal_dart 0.0.3 archive
0.0.1 Jul 5, 2014 Go to the documentation of signal_dart 0.0.1 Download signal_dart 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
5
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
2
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health suggestions

Format lib/hub_connection.dart.

Run dartfmt to format lib/hub_connection.dart.

Format lib/hub_proxy.dart.

Run dartfmt to format lib/hub_proxy.dart.

Format lib/invoke_result.dart.

Run dartfmt to format lib/invoke_result.dart.

Format lib/signal_dart.dart.

Run dartfmt to format lib/signal_dart.dart.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Package is too old. (-100 points)

The package was released more than two years ago.

Maintain CHANGELOG.md. (-20 points)

Changelog entries help clients to follow the progress in your code.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

Maintain an example.

None of the files in your example/ directory matches a known example patterns. Common file name patterns include: main.dart, example.dart or you could also use signal_dart.dart. Packages with multiple examples should use example/readme.md.

Dependencies

Package Constraint Resolved Available
Dev dependencies
browser any