simple_autocomplete_formfield 0.1.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 90

SimpleAutocompleteFormField

A Flutter widget that wraps a TextFormField and assists with autocomplete functionality.

Example

import 'package:flutter/material.dart';
import 'package:simple_autocomplete_formfield/simple_autocomplete_formfield.dart';

class MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: ListView(
        children: <Widget>[
          SimpleAutocompleteFormField<String>(
            itemBuilder: (context, item) => Text(item),
            onSearch: (String search) async => [
                  'a $search',
                  'b $search',
                  'c $search',
                  'd $search',
                  'e $search',
                ],
          ),
        ],
      ),
    );
  }
}

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Simple AutoComplete FormField example',
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  MyHomePageState createState() {
    return new MyHomePageState();
  }
}

[0.1.2] - August 14, 2018

  • Fix missing generic type specifier in itemParser usage.

[0.1.1] - July 21, 2018

  • Fix and improve documentation.

[0.1.0] - July 21, 2018

  • Support Dart 2.0.

[0.0.2] - June 13, 2018

  • Added License (MIT).

[0.0.1] - June 13, 2018

  • First release.

example/main.dart

import 'package:flutter/material.dart';
import 'package:simple_autocomplete_formfield/simple_autocomplete_formfield.dart';

class MyHomePageState extends State<MyHomePage> {
  @override
  Widget build(BuildContext context) {
    return Scaffold(
      body: ListView(
        children: <Widget>[
          SimpleAutocompleteFormField<String>(
            itemBuilder: (context, item) => Text(item),
            onSearch: (String search) async => [
                  'a $search',
                  'b $search',
                  'c $search',
                  'd $search',
                  'e $search',
                ],
          ),
        ],
      ),
    );
  }
}

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  @override
  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Simple AutoComplete FormField example',
      home: MyHomePage(),
    );
  }
}

class MyHomePage extends StatefulWidget {
  @override
  MyHomePageState createState() {
    return new MyHomePageState();
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_autocomplete_formfield: ^0.1.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_autocomplete_formfield/simple_autocomplete_formfield.dart';
  
Version Uploaded Documentation Archive
0.1.2 Aug 14, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.2 Download simple_autocomplete_formfield 0.1.2 archive
0.1.1 Jul 21, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.1 Download simple_autocomplete_formfield 0.1.1 archive
0.1.0 Jul 21, 2018 Go to the documentation of simple_autocomplete_formfield 0.1.0 Download simple_autocomplete_formfield 0.1.0 archive
0.0.2 Jun 13, 2018 Go to the documentation of simple_autocomplete_formfield 0.0.2 Download simple_autocomplete_formfield 0.0.2 archive
0.0.1 Jun 13, 2018 Go to the documentation of simple_autocomplete_formfield 0.0.1 Download simple_autocomplete_formfield 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
80
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
90
Learn more about scoring.

We analyzed this package on Aug 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.11.8
  • Flutter: 0.5.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Suggestions

Package is pre-v1 release.

While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.6 1.14.11
meta 1.1.5 1.1.6
sky_engine 0.0.99
typed_data 1.1.5 1.1.6
vector_math 2.0.6 2.0.8
Dev dependencies
flutter_test