simple_coverflow 0.0.7

  • Example
  • Installing
  • Versions
  • 46

Simple Coverflow for Flutter #

A very basic cover flow implementation to swipe between widgets in Flutter.

It should look something like this:

gif of project

Pull requests certainly welcome.

[0.0.7] - 4/19/18

  • Added ValueNotifier so that other interested classes can keep track of what item is displayed on the CoverFlow.

[0.0.6] - 4/19/18

  • Added made the builder parameter a named argument [itemBuilder] in keeping with flutter conventions.

[0.0.5] - 4/18/18

  • Added [itemCount] field so that users can have a non-infinitely scrolling cover flow. Also adjusted the default viewport value.

[0.0.4] - 4/17/18

  • Bumped versioning constraints to support much later versions of Flutter.

[0.0.3] - 4/12/18

  • Changed typedef of OnDismissedCallback to return the number of the item called rather than the item itself.

[0.0.1] - 4/12/18

  • Initial implementation of simple coverflow.


import 'package:flutter/material.dart';
import 'package:simple_coverflow/simple_coverflow.dart';

void main() => runApp(new MyApp());

class MyApp extends StatelessWidget {
  static List<Container> data = [
    new Container(color:,
    new Container(color:,
    new Container(color: Colors.amber),
    new Container(color: Colors.deepPurple),
    new Container(color:,
    new Container(color:,
    new Container(color: Colors.yellow),
    new Container(color: Colors.greenAccent),
    new Container(color:

  Widget build(BuildContext context) {
    return new MaterialApp(
      title: 'Coverflow Demo',
      theme: new ThemeData(
      home: new Scaffold(
          appBar: new AppBar(
            title: new Text('Coverflow Demo'),
          body: new CoverFlow(itemBuilder: widgetBuilder,
              dismissedCallback: disposeDismissed,
              currentItemChangedCallback: (int index) {print(index);})

  Widget widgetBuilder(BuildContext context, int index) {
    if (data.length == 0) {
      return new Container();
    } else {
      return data[index % data.length];

  disposeDismissed(int item, DismissDirection direction) {
    data.removeAt(item % data.length);

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  simple_coverflow: ^0.0.7

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

import 'package:simple_coverflow/simple_coverflow.dart';
Version Uploaded Documentation Archive
0.0.7 Dec 17, 2018 Go to the documentation of simple_coverflow 0.0.7 Download simple_coverflow 0.0.7 archive
0.0.6 Apr 19, 2018 Go to the documentation of simple_coverflow 0.0.6 Download simple_coverflow 0.0.6 archive
0.0.5 Apr 18, 2018 Go to the documentation of simple_coverflow 0.0.5 Download simple_coverflow 0.0.5 archive
0.0.4 Apr 18, 2018 Go to the documentation of simple_coverflow 0.0.4 Download simple_coverflow 0.0.4 archive
0.0.3 Apr 13, 2018 Go to the documentation of simple_coverflow 0.0.3 Download simple_coverflow 0.0.3 archive
0.0.2 Apr 13, 2018 Go to the documentation of simple_coverflow 0.0.2 Download simple_coverflow 0.0.2 archive
Describes how popular the package is relative to other packages. [more]
Code health derived from static analysis. [more]
Reflects how tidy and up-to-date the package is. [more]
Weighted score of the above. [more]
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0


Detected platforms:

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Analysis issues and suggestions

Fix dependencies in pubspec.yaml.

Running flutter packages pub upgrade failed with the following output:

ERR: The current Dart SDK version is 2.1.1-dev.3.2.flutter-f4afaee422.
 Because simple_coverflow requires SDK version >=1.19.0 <2.1.0, version solving failed.

Health suggestions

Format lib/simple_coverflow.dart.

Run flutter format to format lib/simple_coverflow.dart.

Maintenance issues and suggestions

Fix platform conflicts. (-20 points)

Error(s) prevent platform classification:

Fix dependencies in pubspec.yaml.

Support the latest stable Dart SDK in pubspec.yaml. (-20 points)

The SDK constraint in pubspec.yaml doesn't allow the latest stable Dart SDK release.

Make sure dartdoc successfully runs on your package's source files. (-10 points)

Dependencies were not resolved.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.1.0