simple_rc4 0.1.3

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 51

simple_rc4

Yet another RC4 encryptor.

Usage

A simple usage example:

import 'package:simple_rc4/simple_rc4.dart';

main() {
  RC4 rc4 = new RC4('zonble');
  String input = '中文';
  var bytes = rc4.encodeBytes(utf8.encode(input));
}

0.1.03

  • Fixes typos.

0.1.02

  • Supports Dart 2.

0.1.01

  • Initial version.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_rc4: ^0.1.3

2. Install it

You can install packages from the command line:

with pub:


$ pub get

with Flutter:


$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_rc4/simple_rc4.dart';
  
Version Uploaded Documentation Archive
0.1.3 Aug 21, 2018 Go to the documentation of simple_rc4 0.1.3 Download simple_rc4 0.1.3 archive
0.1.2 Aug 21, 2018 Go to the documentation of simple_rc4 0.1.2 Download simple_rc4 0.1.2 archive
0.1.1 Jul 19, 2018 Go to the documentation of simple_rc4 0.1.1 Download simple_rc4 0.1.1 archive
0.1.0 Jul 19, 2018 Go to the documentation of simple_rc4 0.1.0 Download simple_rc4 0.1.0 archive
0.0.2 Jul 19, 2018 Go to the documentation of simple_rc4 0.0.2 Download simple_rc4 0.0.2 archive
0.0.1 Jul 17, 2018 Go to the documentation of simple_rc4 0.0.1 Download simple_rc4 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
15
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
51
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7

Platforms

Detected platforms: Flutter, web, other

No platform restriction found in primary library package:simple_rc4/simple_rc4.dart.

Maintenance suggestions

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use simple_rc4.dart.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0 <3.0.0
Dev dependencies
test ^1.0.0