simple_sass_transformer 0.0.2+1

  • Installing
  • Versions
  • 27

Dart Sass for Pub

This transfomer simply compiles .scss and .sass files to .css files.

Since it depends on dart-sass, there is no need to have Sass installed.


Add the following lines to your pubspec.yaml:

  simple_sass_transformer: 0.0.2
  - simple_sass_transformer

Assume you have /path/to/file.scss or /path/to/file.sass, add these lines to your index.html:

  <link rel="stylesheet" href="/path/to/file.css">

If relative paths are not so pretty for you, you can instead use package: just like in your .dart files.

@import 'package:your_package_name/styles';



  • Add support for package_resolver


  • Initial version

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:

  simple_sass_transformer: "^0.0.2+1"

2. Install it

You can install packages from the command line:

with pub:

$ pub get

with Flutter:

$ flutter packages get

Alternatively, your editor might support pub get or flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:

      import 'package:simple_sass_transformer/transformer.dart';
Version Uploaded Documentation Archive
0.0.2+1 Mar 12, 2017 Go to the documentation of simple_sass_transformer 0.0.2+1 Download simple_sass_transformer 0.0.2+1 archive
0.0.2 Mar 12, 2017 Go to the documentation of simple_sass_transformer 0.0.2 Download simple_sass_transformer 0.0.2 archive
0.0.1+1 Jan 7, 2017 Go to the documentation of simple_sass_transformer 0.0.1+1 Download simple_sass_transformer 0.0.1+1 archive
0.0.1 Jan 7, 2017 Go to the documentation of simple_sass_transformer 0.0.1 Download simple_sass_transformer 0.0.1 archive


We analyzed this package on Jun 19, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0-dev.63.0
  • pana: 0.11.3


Describes how popular the package is relative to other packages. [more]
0 / 100
Code health derived from static analysis. [more]
48 / 100
Reflects how tidy and up-to-date the package is. [more]
65 / 100
Overall score:
Weighted score of the above. [more]
Learn more about scoring.


Detected platforms: Flutter, other

Platform components identified in package: build, io, isolate.


  • Homepage does not exists.

    We were unable to access at the time of the analysis.

  • Fix analysis and formatting issues.

    Analysis or formatting checks reported 1 error 1 hint.

    Strong-mode analysis of lib/transformer.dart failed with the following error:

    line: 19 col: 14
    The function 'render' isn't defined.

  • Package is getting outdated.

    The package was released 66 weeks ago.

  • The description is too short.

    Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

  • Package is pre-v1 release.

    While there is nothing inherently wrong with versions of 0.*.*, it usually means that the author is still experimenting with the general direction API.

  • Maintain an example.

    Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use simple_sass_transformer.dart.


Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.19.0 <2.0.0
barback ^0.15.2 0.15.2+16
sass ^1.0.0-alpha 1.6.1
Transitive dependencies
args 1.4.3
async 2.0.7
charcode 1.1.1
cli_repl 0.1.3 0.2.0
collection 1.14.10
convert 2.0.1
http 0.11.3+16
http_parser 3.1.2
io 0.3.2+1
js 0.6.1
meta 1.1.5
package_config 1.0.3
package_resolver 1.0.3
path 1.6.1
pool 1.3.5
quiver_hashcode 1.0.0
source_maps 0.10.5
source_span 1.4.0
stack_trace 1.9.2
stream_transform 0.0.14
string_scanner 1.0.2
tuple 1.0.1
typed_data 1.1.5
watcher 0.9.7+8