simple_slider 0.0.2

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 82

Simple Image Slider Widget #

https://pub.dartlang.org/packages/simple_sliderr)

A flutter library to show images in a sliding widget, the library also provides out of the box the ability to automatically cache the images used in the slider.

How to add #

Add this to your package's pubspec.yaml file:

dependencies:
  simple_slider: "^0.0.1"

Add it to your dart file:

import 'package:simple_slider/simple_slider.dart';

How to use #

The Simple slider widget is created with a simple ImageSliderWidget object that takes an array of images to slide

ImageSliderWidget(
            imageUrls: _imageUrls,
            imageBorderRadius: BorderRadius.circular(8.0),
          ),

How it looks #




0.0.1 #

  • TODO: Describe initial release.

example/lib/main.dart

import 'package:flutter/material.dart';
import 'package:simple_slider/simple_slider.dart';

void main() => runApp(new MyApp());

class MyApp extends StatefulWidget {
  @override
  MyAppState createState() {
    return MyAppState();
  }
}

class MyAppState extends State<MyApp> {

  final _imageUrls = [
    "https://spectrumproperties.co.ug/wp-content/uploads/2018/08/IMG_7973.jpg",
    "https://spectrumproperties.co.ug/wp-content/uploads/2018/08/IMG_8427.jpg",
    "https://spectrumproperties.co.ug/wp-content/uploads/2018/08/IMG_8296.jpg",
    "https://spectrumproperties.co.ug/wp-content/uploads/2018/08/IMG_8691.jpg"
  ];


  @override
  Widget build(BuildContext context) {
    var title = "Image Slider Widget";
    return MaterialApp(
      title: title,
      home: Scaffold(
        appBar: AppBar(
          title: Text(title),
        ),
        body: Container(
          child: ImageSliderWidget(
            imageUrls: _imageUrls,
            imageBorderRadius: BorderRadius.circular(8.0),
          ),
        ),
      ),
    );
  }
}

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simple_slider: ^0.0.2

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simple_slider/simple_slider.dart';
  
Version Uploaded Documentation Archive
0.0.2 Sep 21, 2018 Go to the documentation of simple_slider 0.0.2 Download simple_slider 0.0.2 archive
0.0.1 Sep 21, 2018 Go to the documentation of simple_slider 0.0.1 Download simple_slider 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
77
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
70
Overall:
Weighted score of the above. [more]
82
Learn more about scoring.

We analyzed this package on Feb 14, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.13
  • Flutter: 1.2.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/simple_slider.dart. (-1 points)

Analysis of lib/simple_slider.dart reported 2 hints:

line 1 col 8: Unused import: 'dart:async'.

line 6 col 8: Unused import: 'package:flutter/services.dart'.

Format lib/dot_indicator.dart.

Run flutter format to format lib/dot_indicator.dart.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
cached_network_image ^0.4.1 0.4.2 0.5.1
cupertino_icons ^0.1.2 0.1.2
flutter 0.0.0
shared_preferences ^0.4.2 0.4.3 0.5.1+1
Transitive dependencies
async 2.0.8
charcode 1.1.2
collection 1.14.11
convert 2.1.1
crypto 2.0.6
flutter_cache_manager 0.1.2 0.2.0+1
http 0.11.3+17 0.12.0+1
http_parser 3.1.3
meta 1.1.6 1.1.7
path 1.6.2
path_provider 0.4.1 0.5.0+1
sky_engine 0.0.99
source_span 1.5.4
string_scanner 1.0.4
synchronized 1.5.3+2 2.0.2+1
term_glyph 1.1.0
typed_data 1.1.6
uuid 1.0.3 2.0.0
vector_math 2.0.8