simulator_eurl_sasu 0.0.10

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

simulator_eurl_sasu

Ce projet est un simulateur de charges pour les EURL / SASU. Il a été créé dans le but d'appréhender les mécanismes de calcul des différentes charges. Ces derniers évoluant rapidement, n'hésitez pas à proposer une pull-request si vous notez des corrections à apporter.

Usage

Vous pouvez réaliser une simulation facilement :

    import 'package:simulator_eurl_sasu/simulator_eurl_sasu.dart';

    main() {
      print(serviceSimulationEurl.findBestSimulation(100000.00, 6000.00));
      print(serviceSimulationSasu.findBestSimulation(100000.00, 6000.00));
    }

Changelog

0.0.1

  • Initial version, created by Matthieu Maquevice

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  simulator_eurl_sasu: ^0.0.10

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:simulator_eurl_sasu/simulator_eurl_sasu.dart';
  
Version Uploaded Documentation Archive
0.0.10 May 23, 2017 Go to the documentation of simulator_eurl_sasu 0.0.10 Download simulator_eurl_sasu 0.0.10 archive
0.0.8 Mar 24, 2017 Go to the documentation of simulator_eurl_sasu 0.0.8 Download simulator_eurl_sasu 0.0.8 archive
0.0.7 Sep 19, 2016 Go to the documentation of simulator_eurl_sasu 0.0.7 Download simulator_eurl_sasu 0.0.7 archive
0.0.6 Sep 19, 2016 Go to the documentation of simulator_eurl_sasu 0.0.6 Download simulator_eurl_sasu 0.0.6 archive
0.0.5 Sep 19, 2016 Go to the documentation of simulator_eurl_sasu 0.0.5 Download simulator_eurl_sasu 0.0.5 archive
0.0.4 Aug 31, 2016 Go to the documentation of simulator_eurl_sasu 0.0.4 Download simulator_eurl_sasu 0.0.4 archive
0.0.3 Jun 8, 2016 Go to the documentation of simulator_eurl_sasu 0.0.3 Download simulator_eurl_sasu 0.0.3 archive
0.0.2 Jun 8, 2016 Go to the documentation of simulator_eurl_sasu 0.0.2 Download simulator_eurl_sasu 0.0.2 archive
0.0.1 Jun 8, 2016 Go to the documentation of simulator_eurl_sasu 0.0.1 Download simulator_eurl_sasu 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Issues and suggestions

Support Dart 2 in pubspec.yaml.

The SDK constraint in pubspec.yaml doesn't allow the Dart 2.0.0 release. For information about upgrading it to be Dart 2 compatible, please see https://www.dartlang.org/dart-2#migration.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=1.8.0 <2.0.0