slide_container 1.0.7

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 84

Slide Container

A container that can be slid vertically and horizontally with a smooth dampened motion.

Offers a handful of callbacks for customization and handles both drag distance and velocity to validate swipe gestures.

Features a customized GestureDetector to reduce nested GestureDetector conflicts.

Build the example folder with flutter run for a demo, or check the video in this blog post:

https://tengio.com/blog/flutter-slide-container/

Install instructions and doc are available here:

https://pub.dartlang.org/packages/slide_container

1.0.7 - 2018-11-29

  • Added the SlideContainerController to allow a manual force slide in a given direction.
  • Updated example app to showcase the new SlideContainerController.

1.0.6 - 2018-10-25

  • Fixed Flutter analysis warnings.

1.0.5 - 2018-10-25

  • Fixed Flutter analysis warnings.

1.0.4 - 2018-10-25

  • Added onSlideValidated and onSlideUnvalidated callbacks.

1.0.3 - 2018-10-10

  • Improved logic to reduce nested GestureDetector conflicts. Now if the container as been slid to its max extent in one direction, trying to slid it more in this direction will not count as a gesture, thus allowing other GestureDetectors to get and handle the event.

1.0.2 - 2018-10-09

  • Updated README.

1.0.1 - 2018-10-06

  • Added support for horizontal sliding.
  • Breaking change
    • Renamed class VerticalSlideContainer to SlideContainer
    • Renamed enum VerticalSlideContainerDirection to SlideContainerDirection and changed its values.

1.0.0 - 2018-10-05

  • Initial release.

example/README.md

Slide Container Example

Demo of the Slide Container.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  slide_container: ^1.0.7

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:slide_container/slide_container.dart';
  
Version Uploaded Documentation Archive
1.0.7 Nov 29, 2018 Go to the documentation of slide_container 1.0.7 Download slide_container 1.0.7 archive
1.0.6 Oct 25, 2018 Go to the documentation of slide_container 1.0.6 Download slide_container 1.0.6 archive
1.0.5 Oct 25, 2018 Go to the documentation of slide_container 1.0.5 Download slide_container 1.0.5 archive
1.0.4 Oct 25, 2018 Go to the documentation of slide_container 1.0.4 Download slide_container 1.0.4 archive
1.0.3 Oct 10, 2018 Go to the documentation of slide_container 1.0.3 Download slide_container 1.0.3 archive
1.0.2 Oct 9, 2018 Go to the documentation of slide_container 1.0.2 Download slide_container 1.0.2 archive
1.0.1 Oct 6, 2018 Go to the documentation of slide_container 1.0.1 Download slide_container 1.0.1 archive
1.0.0 Oct 6, 2018 Go to the documentation of slide_container 1.0.0 Download slide_container 1.0.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
69
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
100
Overall:
Weighted score of the above. [more]
84
Learn more about scoring.

We analyzed this package on Dec 5, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.1.0
  • pana: 0.12.7
  • Flutter: 1.0.0

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8