slownie 0.2.0

  • README.md
  • CHANGELOG.md
  • Installing
  • Versions
  • 0

slownie

Build Status

slownie is numbers to words converter in polish. It's a port of this PHP version

License

MIT License.

Usage

A simple usage example:

import 'package:slownie/slownie.dart';

main() {
 print(slownie('44'));
 //printed text: 'czterdzieści cztery'
} 

Features and bugs

Please file feature requests and bugs at the issue tracker.

0.2

FIXES

  • fix minus sign print

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  slownie: ^0.2.0

2. Install it

You can install packages from the command line:

with pub:


$ pub get

Alternatively, your editor might support pub get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:slownie/slownie.dart';
  
Version Uploaded Documentation Archive
0.2.0 Mar 4, 2016 Go to the documentation of slownie 0.2.0 Download slownie 0.2.0 archive
0.1.0 Nov 16, 2014 Go to the documentation of slownie 0.1.0 Download slownie 0.1.0 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
0
Health:
Code health derived from static analysis. [more]
0
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
0
Overall:
Weighted score of the above. [more]
0
Learn more about scoring.

The package version is not analyzed, because it does not support Dart 2. Until this is resolved, the package will receive a health and maintenance score of 0.

Health issues and suggestions

Fix lib/slownie.dart. (-82.20 points)

Analysis of lib/slownie.dart failed with 6 errors, including:

line 129 col 30: The operator '[]' isn't defined for the class 'Object'.

line 137 col 35: The operator '[]' isn't defined for the class 'Object'.

line 141 col 24: The operator '[]' isn't defined for the class 'Object'.

line 143 col 24: The operator '[]' isn't defined for the class 'Object'.

line 147 col 57: The operator '[]' isn't defined for the class 'Object'.

Maintenance issues and suggestions

Add SDK constraint in pubspec.yaml. (-50 points)

For information about setting SDK constraint, please see https://www.dartlang.org/tools/pub/pubspec#sdk-constraints.

Fix platform conflicts. (-20 points)

Low code quality prevents platform classification.

Package is too old. (-100 points)

The package was released more than two years ago.

The description is too short. (-20 points)

Add more detail about the package, what it does and what is its target use case. Try to write at least 60 characters.

Maintain an example. (-10 points)

Create a short demo in the example/ directory to show how to use this package. Common file name patterns include: main.dart, example.dart or you could also use slownie.dart.

Dependencies

Package Constraint Resolved Available
Dev dependencies
test >=0.12.0 <0.13.0