slydepay_payment 0.0.4

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • new71

💳 Slydepay Plugin for Flutter

A flutter plugin to integrate the Slydepay plugin for iOS and Android. Currently only implemented for android. IOS plugin will be implemented as well. Pull requests are always welcome.

Features

  • [x] Android (iOS Coming Soon)

    • [x] Slydepay Payment
    • [x] VISA, MTN Mobile money, Vodafone payment
    • [x] All supported payment options with your account
  • Supported formats

Screenshots

Show some ❤️ and star the repo to support the project

  • Please note this is a plugin only. This plugin has used the Android SDK

Slydepay Account (Skip this if you have an active Merchant Account)

Create a Merchant Account on Slydepay

Follow the link to get started on that: (Slydepay Merchant Account)

Usage

To use this plugin :

  dependencies:
    flutter:
      sdk: flutter
    slydepay_payment:

To call payment procedure:

import 'package:slydepay_payment/slydepay_payment.dart';

List<dynamic> result = await SlydepayPayment.openSlydepayPaymentDialog(
      amount: amount,
      itemName: itemName,
      description: desc,
      customerName: customerName,
      customerEmail: customerEmail,
      orderCode: orderCode,
      phoneNumber: phoneNumber,
      merchantKey: merchantKey,
      merchantEmail: merchantEmail
    );
    print("RESULT TYPE " + result[0]); // 1: SUCCESS, 2: FAILED, 3: CANCELLED
    print("MSG " + result[1]);

Special Thanks

@norrisboateng For his sdk Slydepay-android-sdk-with-sample

TODO

  • [ ] better error handling

Created & Maintained By

Vijay Rathod

If you found this plugin helpful and want to thank me, consider buying me a cup of ☕

License

Copyright 2018 awoshe.com

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

0.0.3

*Bug fixes

example/README.md

💳 Slydepay Plugin for Flutter

A flutter plugin to integrate the Slydepay plugin for iOS and Android. Currently only implemented for android. IOS plugin will be implemented as well. Pull requests are always welcome.

Features

  • [x] Android (iOS Coming Soon)

    • [x] Slydepay Payment
    • [x] VISA, MTN Mobile money, Vodafone payment
    • [x] All supported payment options with your account
  • Supported formats

Screenshots

<img src="screenshots/screen1.png" height="300em" /> <img src="screenshots/screen2.png" height="300em" />

Show some ❤️ and star the repo to support the project

  • Please note this is a plugin only. This plugin has used the Android SDK

Usage

To use this plugin :

  dependencies:
    flutter:
      sdk: flutter
    slydepay_payment:

To call payment procedure:

import 'package:slydepay_payment/slydepay_payment.dart';

List<dynamic> result = await SlydepayPayment.openSlydepayPaymentDialog(
      amount: amount,
      itemName: itemName,
      description: desc,
      customerName: customerName,
      customerEmail: customerEmail,
      orderCode: orderCode,
      phoneNumber: phoneNumber,
      merchantKey: merchantKey,
      merchantEmail: merchantEmail
    );
    print("RESULT TYPE " + result[0]); // 1: SUCCESS, 2: FAILED, 3: CANCELLED
    print("MSG " + result[1]);

Special Thanks

@norrisboateng For his sdk Slydepay-android-sdk-with-sample

TODO

  • [ ] better error handling

Created & Maintained By

Vijay Rathod

If you found this plugin helpful and want to thank me, consider buying me a cup of ☕

License

Copyright 2018 awoshe.com

Licensed under the Apache License, Version 2.0 (the "License");
you may not use this file except in compliance with the License.
You may obtain a copy of the License at

   http://www.apache.org/licenses/LICENSE-2.0

Unless required by applicable law or agreed to in writing, software
distributed under the License is distributed on an "AS IS" BASIS,
WITHOUT WARRANTIES OR CONDITIONS OF ANY KIND, either express or implied.
See the License for the specific language governing permissions and
limitations under the License.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  slydepay_payment: ^0.0.4

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:slydepay_payment/slydepay_payment.dart';
  
Version Uploaded Documentation Archive
0.0.4 Oct 30, 2018 Go to the documentation of slydepay_payment 0.0.4 Download slydepay_payment 0.0.4 archive
0.0.3 Oct 30, 2018 Go to the documentation of slydepay_payment 0.0.3 Download slydepay_payment 0.0.3 archive
0.0.2 Oct 28, 2018 Go to the documentation of slydepay_payment 0.0.2 Download slydepay_payment 0.0.2 archive
0.0.1 Oct 28, 2018 Go to the documentation of slydepay_payment 0.0.1 Download slydepay_payment 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
50
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
71
Learn more about scoring.

We analyzed this package on Nov 14, 2018, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.0.0
  • pana: 0.12.6
  • Flutter: 0.11.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Maintenance suggestions

Package is pre-v0.1 release. (-10 points)

While there is nothing inherently wrong with versions of 0.0.*, it usually means that the author is still experimenting with the general direction of the API.

The description is too long. (-10 points)

Search engines will display only the first part of the description. Try to keep it under 180 characters.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8