smooth_star_rating 1.0.1

  • README.md
  • CHANGELOG.md
  • Example
  • Installing
  • Versions
  • 93

A Star rating with touch and swipe rate enabled

  • Supports half rate and full rate (1.0 or 0.5)
  • Swipe for incrementing/decrementing rate amount
  • Change star body and boundary colors independently
  • Control size of the star rating
  • Set your desired total Star count
  • Now Supports click-to-rate

Getting Started #

In your flutter project add the dependency:

    dependencies:
        ...
        smooth_star_rating: 1.0.1

Usage example #

import 'package:smooth_star_rating/smooth_star_rating.dart'; 
SmoothStarRating(
          allowHalfRating: false,
          onRatingChanged: (v) {
            rating = v;
            setState(() {});
          },
          starCount: 5,
          rating: rating,
          size: 40.0,
          color: Colors.green,
          borderColor: Colors.green,
        )

Constructor parameters #

allowHalfRating                 -   Whether to use whole number for rating(1.0  or 0.5)
onRatingChanged(int rating)     -   Rating changed callback
starCount                       -   The maximum amount of stars
rating                          -   The current value of rating
size                            -   The size of a single star
color                           -   The body color of star
borderColor                     -   The border color of star

Screenshots #

Full Rating #

alt text

Half Rating #

alt text

[1.0.1] - 21/11/2018

Added click-to-rate feature #

[0.0.2] - 02/09/2018

rating bug fixed #

[0.0.1] - 02/09/2018

initial release. #

example/README.md

example #

A new Flutter project.

Getting Started #

For help getting started with Flutter, view our online documentation.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  smooth_star_rating: ^1.0.1

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:smooth_star_rating/smooth_star_rating.dart';
  
Version Uploaded Documentation Archive
1.0.1 Nov 21, 2018 Go to the documentation of smooth_star_rating 1.0.1 Download smooth_star_rating 1.0.1 archive
1.0.0 Sep 4, 2018 Go to the documentation of smooth_star_rating 1.0.0 Download smooth_star_rating 1.0.0 archive
0.0.4 Sep 2, 2018 Go to the documentation of smooth_star_rating 0.0.4 Download smooth_star_rating 0.0.4 archive
0.0.3 Sep 2, 2018 Go to the documentation of smooth_star_rating 0.0.3 Download smooth_star_rating 0.0.3 archive
0.0.2 Sep 2, 2018 Go to the documentation of smooth_star_rating 0.0.2 Download smooth_star_rating 0.0.2 archive
0.0.1 Sep 2, 2018 Go to the documentation of smooth_star_rating 0.0.1 Download smooth_star_rating 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
94
Health:
Code health derived from static analysis. [more]
100
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
80
Overall:
Weighted score of the above. [more]
93
Learn more about scoring.

We analyzed this package on Mar 6, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.3.3

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health suggestions

Fix lib/smooth_star_rating.dart. (-0.50 points)

Analysis of lib/smooth_star_rating.dart reported 1 hint:

line 4 col 8: Duplicate import.

Maintenance suggestions

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.0.0-dev.68.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test