smssdk 0.0.6

  • README.md
  • Example
  • Installing
  • Versions
  • 59

smssdk #

轻松实现手机短信验证功能,目前只支持86的手机号

注册应用获取appKey和appSecret #

(1)到Mob官网注册成为Mob开发者; (2)到应用管理后台新建应用。

iOS #

在项目中的info.plist文件中添加键值对,键分别为 MOBAppKey 和 MOBAppSecret ,值为步骤一申请的appKey和appSecret。 会提示NSContactsUsageDescription,目前没有接入好友关系功能,可以不用理会。

记得添加多语言支持,不然提示信息不会根据手机语言而更改 #

Android #

在build.gradle里添加

buildscript {
    repositories {
        google()
        jcenter()
        maven {
            url "http://mvn.mob.com/android"
        }
    }

    dependencies {
        classpath 'com.android.tools.build:gradle:3.2.1'
        classpath 'com.mob.sdk:MobSDK:+'
    }
}

allprojects {
    repositories {
        google()
        jcenter()
        maven {
            url "http://mvn.mob.com/android"
        }
    }
}

在Manifest清单文件中配置:tools:replace=”android:name”

<application
   tools:replace="android:name">

用法 #

  @override
  void initState() {
    Smssdk.init("2a87330c459a8", "f1509b680c66f561bf1519e891c200d3");
    super.initState();
  }

  var result = await Smssdk.getCode(phone);

  var submit = await Smssdk.commitCode(phone, code);

example/README.md

smssdk_example #

Demonstrates how to use the smssdk plugin.

Getting Started #

This project is a starting point for a Flutter application.

A few resources to get you started if this is your first Flutter project:

For help getting started with Flutter, view our online documentation, which offers tutorials, samples, guidance on mobile development, and a full API reference.

Use this package as a library

1. Depend on it

Add this to your package's pubspec.yaml file:


dependencies:
  smssdk: ^0.0.6

2. Install it

You can install packages from the command line:

with Flutter:


$ flutter packages get

Alternatively, your editor might support flutter packages get. Check the docs for your editor to learn more.

3. Import it

Now in your Dart code, you can use:


import 'package:smssdk/smssdk.dart';
  
Version Uploaded Documentation Archive
0.0.6 Mar 22, 2019 Go to the documentation of smssdk 0.0.6 Download smssdk 0.0.6 archive
0.0.5 Mar 21, 2019 Go to the documentation of smssdk 0.0.5 Download smssdk 0.0.5 archive
0.0.4 Mar 21, 2019 Go to the documentation of smssdk 0.0.4 Download smssdk 0.0.4 archive
0.0.3 Mar 21, 2019 Go to the documentation of smssdk 0.0.3 Download smssdk 0.0.3 archive
0.0.2 Mar 21, 2019 Go to the documentation of smssdk 0.0.2 Download smssdk 0.0.2 archive
0.0.1 Mar 20, 2019 Go to the documentation of smssdk 0.0.1 Download smssdk 0.0.1 archive
Popularity:
Describes how popular the package is relative to other packages. [more]
38
Health:
Code health derived from static analysis. [more]
99
Maintenance:
Reflects how tidy and up-to-date the package is. [more]
50
Overall:
Weighted score of the above. [more]
59
Learn more about scoring.

We analyzed this package on Apr 22, 2019, and provided a score, details, and suggestions below. Analysis was completed with status completed using:

  • Dart: 2.2.0
  • pana: 0.12.14
  • Flutter: 1.4.7

Platforms

Detected platforms: Flutter

References Flutter, and has no conflicting libraries.

Health issues and suggestions

Document public APIs. (-1 points)

13 out of 13 API elements have no dartdoc comment.Providing good documentation for libraries, classes, functions, and other API elements improves code readability and helps developers find and use your API.

Format lib/smssdk.dart.

Run flutter format to format lib/smssdk.dart.

Maintenance issues and suggestions

Provide a file named CHANGELOG.md. (-20 points)

Changelog entries help developers follow the progress of your package. See the example generated by stagehand.

The package description is too short. (-20 points)

Add more detail to the description field of pubspec.yaml. Use 60 to 180 characters to describe the package, what it does, and its target use case.

Package is pre-v0.1 release. (-10 points)

While nothing is inherently wrong with versions of 0.0.*, it might mean that the author is still experimenting with the general direction of the API.

Dependencies

Package Constraint Resolved Available
Direct dependencies
Dart SDK >=2.1.0 <3.0.0
flutter 0.0.0
Transitive dependencies
collection 1.14.11
meta 1.1.6 1.1.7
sky_engine 0.0.99
typed_data 1.1.6
vector_math 2.0.8
Dev dependencies
flutter_test